# CVE-2026-41041: Path traversal in Apache Gravitino

> Attackers can inject unencoded identifiers into MCP REST client URLs to traverse paths and access unintended API endpoints in Apache Gravitino.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 13 Jul 2026
- **Also known as:** GHSA-p87c-hmgx-wg42, PYSEC-2026-3441

## What is CVE-2026-41041?

CVE-2026-41041 is a critical path traversal vulnerability in Apache Gravitino, published on 13 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

URL path injection via unencoded user-supplied identifiers vulnerability in Apache Gravitino.

This issue affects Apache Gravitino: from 1.0.0 before 1.2.1.

Users are recommended to upgrade to version 1.2.1, which fixes the issue.

Weakness: CWE-177 (Improper Handling of URL Encoding (Hex Encoding))

## Which versions are affected by CVE-2026-41041?

1 open source package ship an affected version, including apache-gravitino. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-gravitino` | PyPI | From 1.0.0 | 1.2.1 |

Products: Apache Gravitino.

## How do I fix CVE-2026-41041?

Upgrade apache-gravitino to 1.2.1 or later.

## Is CVE-2026-41041 being exploited?

There is no known exploitation of CVE-2026-41041 in the wild and no public exploit code.

## Other vulnerabilities in Apache Gravitino

- [CVE-2026-49876](https://insights.sbomify.com/CVE-2026-49876/): Server-side request forgery in Apache Gravitino (medium 6.5)
- [CVE-2025-53648](https://insights.sbomify.com/CVE-2025-53648/): Apache Gravitino: SQL misconfiguration can access or truncate files (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41041 and fix it if it is affected.

What it is: CVE-2026-41041 is a critical path traversal vulnerability in Apache Gravitino, published on 13 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41041 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-gravitino (PyPI): affected from 1.0.0; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41041/ (Markdown: https://insights.sbomify.com/CVE-2026-41041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41041
- OSV: https://osv.dev/vulnerability/CVE-2026-41041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41041/
Summaries are generated and may contain mistakes; the official description above is the record.
