# CVE-2026-41042: Code injection in Apache Gravitino

> Unauthenticated attackers can execute arbitrary Java code on Apache Gravitino servers by supplying a malicious H2 JDBC URL to the testConnection API.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-2q68-xwfj-2rpc

## What is CVE-2026-41042?

CVE-2026-41042 is a critical code injection vulnerability in Apache Gravitino, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unauthenticated callers can supply a malicious H2 JDBC URL through the testConnection API, which executes arbitrary Java code on the server via H2's INIT parameter. Vulnerability in Apache Gravitino.

This issue affects Apache Gravitino: before 1.2.1.

Users are recommended to upgrade to version 1.2.1, which fixes the issue.

This issue only happens when using H2, and H2 is mainly used for testing and local development. Also, Gravitino is typically deployed in the internal environment, so the severity is low.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-41042?


## How do I fix CVE-2026-41042?

No fix has been published for CVE-2026-41042 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-41042 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41042 exists.

Public exploit code:

- POC for CVE-2026-41042 (github_poc): https://github.com/Lulztigre/cve-2026-41042
- Apache Gravitino < 1.2.1 - Unauthenticated Remote Code Execution (nuclei): http/cves/2026/CVE-2026-41042.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41042 and fix it if it is affected.

What it is: CVE-2026-41042 is a critical code injection vulnerability in Apache Gravitino, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41042 exists.

Affected product: Apache Gravitino. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41042/ (Markdown: https://insights.sbomify.com/CVE-2026-41042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41042
- OSV: https://osv.dev/vulnerability/CVE-2026-41042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41042/
Summaries are generated and may contain mistakes; the official description above is the record.
