CVE-2026-41043 Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues
An authenticated attacker can execute malicious scripts in the ActiveMQ web console by injecting HTML into JMS selector fields when browsing queues.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41043?
CVE-2026-41043 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web.
An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field.
This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Which versions are affected by CVE-2026-41043?
13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
activemq Bitnami | All versions | 5.19.6, 6.2.5 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
7 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
Products include Apache Activemq, Apache Activemq Web.
How do I fix CVE-2026-41043?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.6 or 6.2.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-41043 being exploited?
There is no known exploitation of CVE-2026-41043 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-41043, DEBIAN-CVE-2026-41043, GHSA-2jp3-2923-9h52, MINI-6hqf-5mjq-5jwx, MINI-99x3-rwcf-g89x, MINI-vc54-3cgr-ccm9 and 3 more.