# CVE-2026-41043: Apache ActiveMQ, Apache ActiveMQ Web: ActiveMQ Web Console - XSS vulnerability when browsing queues

> An authenticated attacker can execute malicious scripts in the ActiveMQ web console by injecting HTML into JMS selector fields when browsing queues.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** BIT-activemq-2026-41043, DEBIAN-CVE-2026-41043, GHSA-2jp3-2923-9h52, MINI-6hqf-5mjq-5jwx, MINI-99x3-rwcf-g89x, MINI-vc54-3cgr-ccm9, MINI-wvqq-gh98-5gxh, ROOT-APP-MAVEN-CVE-2026-41043, UBUNTU-CVE-2026-41043

## What is CVE-2026-41043?

CVE-2026-41043 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache ActiveMQ, Apache ActiveMQ Web.

An authenticated attacker can show malicious content when browsing queues in the web console by overriding the content type to be HTML (instead of XML) and by injecting HTML into a JMS selector field.

This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Web: before 5.19.6, from 6.0.0 before 6.2.5.

Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41043?

13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.5 |
| `activemq` | Bitnami | All versions | 5.19.6, 6.2.5 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.6 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.5 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.5 |

Products: Apache Activemq, Apache Activemq Web.

## How do I fix CVE-2026-41043?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.6 or 6.2.5.

## Is CVE-2026-41043 being exploited?

There is no known exploitation of CVE-2026-41043 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41043 and fix it if it is affected.

What it is: CVE-2026-41043 is a medium-severity cross-site scripting vulnerability in Apache Activemq, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41043 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.5
- activemq (Bitnami): affected all versions; fixed in 5.19.6, 6.2.5
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.5
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:apache-activemq (Maven): affected all versions; fixed in 5.19.6
- org.apache.activemq:apache-activemq (Maven): affected from 6.0.0; fixed in 6.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41043/ (Markdown: https://insights.sbomify.com/CVE-2026-41043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41043
- OSV: https://osv.dev/vulnerability/CVE-2026-41043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41043/
Summaries are generated and may contain mistakes; the official description above is the record.
