CVE-2026-41044 Apache ActiveMQ Vulnerable to Code Injection
Authenticated attackers can achieve remote code execution on Apache ActiveMQ brokers by exploiting Jolokia MBeans to load malicious Spring XML configurations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41044?
CVE-2026-41044 is a high-severity code injection vulnerability in Apache Activemq, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All.
An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file.
Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec().
This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ All: before 5.19.6, from 6.0.0 before 6.2.5.
Users are recommended to upgrade to version 6.2.5 or 5.19.6, which fixes the issue.
Which versions are affected by CVE-2026-41044?
13 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.5 |
activemq Bitnami | All versions | 5.19.6, 6.2.5 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
7 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.6 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.6 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.5 |
Products include Apache Activemq, Apache Activemq Broker.
How do I fix CVE-2026-41044?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.6 or 6.2.5.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-41044 being exploited?
There is no known exploitation of CVE-2026-41044 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-41044, DEBIAN-CVE-2026-41044, GHSA-mr6m-xj7v-3cv3, MINI-6rxj-8362-qp8c, MINI-9gpj-2xx7-cm24, MINI-f4w5-hf5q-gcf4 and 3 more.