# CVE-2026-41052: Rancher Privilege Escalation from Project Owner to Host

> Users with Project Owner role can escalate privileges to host level in Rancher, requiring an upgrade to patched versions.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** GHSA-vx8h-4prv-g744, GO-2026-5876

## What is CVE-2026-41052?

CVE-2026-41052 is a critical vulnerability in SUSE Rancher, published on 29 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper privilege handling could be used by users with Project Owner role to escalate privileges, in Rancher versions 2.14 before 2.14.2, 2.13 before 2.13.6, and 2.12 before 2.12.10.

Weakness: CWE-305 (Authentication Bypass by Primary Weakness)

## Which versions are affected by CVE-2026-41052?

9 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260513182521-2800aaac25b5 |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260513182521-2800aaac25b5 |
| `github.com/rancher/rancher` | Go | All versions | 0.0.0-20260513182521-2800aaac25b5 |
| `github.com/rancher/rancher` | Go | From 2.12.0 | 2.12.10 |
| `github.com/rancher/rancher` | Go | From 2.12.0 | 2.12.10 |
| `github.com/rancher/rancher` | Go | From 2.13.0 | 2.13.6 |
| `github.com/rancher/rancher` | Go | From 2.13.0 | 2.13.6 |
| `github.com/rancher/rancher` | Go | From 2.14.0 | 2.14.2 |
| `github.com/rancher/rancher` | Go | From 2.14.0 | 2.14.2 |

Products: Suse Rancher.

## How do I fix CVE-2026-41052?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 0.0.0-20260513182521-2800aaac25b5, 2.12.10, 2.13.6 or 2.14.2.

## Is CVE-2026-41052 being exploited?

There is no known exploitation of CVE-2026-41052 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36782](https://insights.sbomify.com/CVE-2021-36782/): Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41052 and fix it if it is affected.

What it is: CVE-2026-41052 is a critical vulnerability in SUSE Rancher, published on 29 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41052 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260513182521-2800aaac25b5
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260513182521-2800aaac25b5
- github.com/rancher/rancher (Go): affected all versions; fixed in 0.0.0-20260513182521-2800aaac25b5
- github.com/rancher/rancher (Go): affected from 2.12.0; fixed in 2.12.10
- github.com/rancher/rancher (Go): affected from 2.12.0; fixed in 2.12.10
- github.com/rancher/rancher (Go): affected from 2.13.0; fixed in 2.13.6
- github.com/rancher/rancher (Go): affected from 2.13.0; fixed in 2.13.6
- github.com/rancher/rancher (Go): affected from 2.14.0; fixed in 2.14.2
- github.com/rancher/rancher (Go): affected from 2.14.0; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41052/ (Markdown: https://insights.sbomify.com/CVE-2026-41052/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41052
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41052
- OSV: https://osv.dev/vulnerability/CVE-2026-41052

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41052/
Summaries are generated and may contain mistakes; the official description above is the record.
