# CVE-2026-41067: Astro: XSS via incomplete `</script>` sanitization in `define:vars` allows case-insensitive and whitespace-based bypass

> Attackers can bypass script sanitization in Astro's define:vars directive to inject arbitrary JavaScript, enabling cross-site scripting attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-j687-52p2-xcff

## What is CVE-2026-41067?

CVE-2026-41067 is a medium-severity cross-site scripting vulnerability in withastro astro, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Astro is a web framework. Prior to 6.1.6, the defineScriptVars function in Astro's server-side rendering pipeline uses a case-sensitive regex /<\/script>/g to sanitize values injected into inline <script> tags via the define:vars directive. HTML parsers close <script> elements case-insensitively and also accept whitespace or / before the closing >, allowing an attacker to bypass the sanitization with payloads like </Script>, </script >, or </script/> and inject arbitrary HTML/JavaScript. This vulnerability is fixed in 6.1.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41067?

2 open source packages ship an affected version, including astro. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astro` | npm | All versions | 6.1.6 |
| `astro` | npm | All versions | 6.1.6 |

Products: Astro Astro.

## How do I fix CVE-2026-41067?

Upgrade astro to 6.1.6 or later.

## Is CVE-2026-41067 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41067 exists.

## Other vulnerabilities in withastro astro

- [CVE-2024-56159](https://insights.sbomify.com/CVE-2024-56159/): Server source code is exposed to the public if sourcemaps are enabled (high 7.8)
- [CVE-2026-54299](https://insights.sbomify.com/CVE-2026-54299/): Astro: Host header SSRF in prerendered error page fetch (high 7.5)
- [CVE-2025-59837](https://insights.sbomify.com/CVE-2025-59837/): astro allows bypass of image proxy domain validation leading to SSRF and potential XSS (high 7.2)
- [CVE-2026-50146](https://insights.sbomify.com/CVE-2026-50146/): Astro: Reflected XSS via unescaped slot name (high 7.1)
- [CVE-2025-64764](https://insights.sbomify.com/CVE-2025-64764/): Astro is vulnerable to Reflected XSS via the server islands feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41067 and fix it if it is affected.

What it is: CVE-2026-41067 is a medium-severity cross-site scripting vulnerability in withastro astro, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41067 exists.

Affected packages and fixed versions:
- astro (npm): affected all versions; fixed in 6.1.6
- astro (npm): affected all versions; fixed in 6.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41067/ (Markdown: https://insights.sbomify.com/CVE-2026-41067/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41067
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41067
- OSV: https://osv.dev/vulnerability/CVE-2026-41067

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41067/
Summaries are generated and may contain mistakes; the official description above is the record.
