# CVE-2026-41068: Kyverno: Cross-Namespace Read Bypasses RBAC Isolation (CVE-2026-22039 Incomplete Fix)

> Namespace admins can bypass RBAC to read ConfigMaps from any namespace via Kyverno's privileged service account, exposing sensitive cluster data.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** BIT-kyverno-2026-41068, ECHO-b1b9-37a5-8821, GHSA-cvq5-hhx3-f99p, GO-2026-5337, MINI-2wcq-6jh8-ghjc, MINI-5ppv-qm35-6vjf, MINI-79xh-frc2-c226, MINI-8h5x-cjvf-27w9, MINI-cm3f-gxwr-jwm5, MINI-g9wm-rxxc-wh4v, MINI-gp7m-7w29-gm8r, MINI-hrrc-266c-h9v5, MINI-phh6-hphf-3cx6, MINI-q7rw-7m2c-375x, MINI-qmw4-hhvf-q832, MINI-r3mx-9ccc-hcvf, MINI-rxmm-9h3f-2hpc, MINI-vpx3-j55p-fhjv, MINI-w98v-cf79-32f9

## What is CVE-2026-41068?

CVE-2026-41068 is a high-severity missing authorization vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno is a policy engine designed for cloud native platform engineering teams. The patch for CVE-2026-22039 fixed cross-namespace privilege escalation in Kyverno's `apiCall` context by validating the `URLPath` field. However, the ConfigMap context loader has the identical vulnerability — the `configMap.namespace` field accepts any namespace with zero validation, allowing a namespace admin to read ConfigMaps from any namespace using Kyverno's privileged service account. This is a complete RBAC bypass in multi-tenant Kubernetes clusters. An updated fix is available in version 1.17.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41068?

4 open source packages ship an affected version, including github.com/kyverno/kyverno and kyverno. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kyverno/kyverno` | Go | All versions | None |
| `github.com/kyverno/kyverno` | Go | All versions to 1.17.1 | None |
| `github.com/kyverno/kyverno` | Go | All versions to 1.17.1 | None |
| `kyverno` | Bitnami | All versions | 1.17.2 |

Products: Kyverno Kyverno.

## How do I fix CVE-2026-41068?

Upgrade to a fixed version.

## Is CVE-2026-41068 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41068 exists.

## Other vulnerabilities in kyverno

- [CVE-2026-22039](https://insights.sbomify.com/CVE-2026-22039/): Kyverno Cross-Namespace Privilege Escalation via Policy apiCall (critical 10.0)
- [CVE-2026-4789](https://insights.sbomify.com/CVE-2026-4789/): CVE-2026-4789 (critical 9.8)
- [CVE-2025-46342](https://insights.sbomify.com/CVE-2025-46342/): Kyverno vulnerable to bypass of policy rules that use namespace selectors in match statements (high 8.6)
- [CVE-2026-41323](https://insights.sbomify.com/CVE-2026-41323/): Kyverno: ServiceAccount token leaked to external servers via apiCall service URL (high 8.1)
- [CVE-2026-40868](https://insights.sbomify.com/CVE-2026-40868/): kyverno apicall servicecall implicit bearer token injection leaks kyverno serviceaccount token (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41068 and fix it if it is affected.

What it is: CVE-2026-41068 is a high-severity missing authorization vulnerability in kyverno, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41068 exists.

Affected packages and fixed versions:
- github.com/kyverno/kyverno (Go): affected all versions; no fix listed
- github.com/kyverno/kyverno (Go): affected all versions up to 1.17.1; no fix listed
- github.com/kyverno/kyverno (Go): affected all versions up to 1.17.1; no fix listed
- kyverno (Bitnami): affected all versions; fixed in 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41068/ (Markdown: https://insights.sbomify.com/CVE-2026-41068/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41068
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41068
- OSV: https://osv.dev/vulnerability/CVE-2026-41068

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41068/
Summaries are generated and may contain mistakes; the official description above is the record.
