# CVE-2026-41073: RT: Spreadsheet downloads vulnerable to CSV/formula injection in Microsoft Excel and similar apps

> Attackers can inject malicious formulas into RT spreadsheet exports, leading to code execution when victims open the files in spreadsheet applications.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 23 May 2026
- **Also known as:** DEBIAN-CVE-2026-41073, GHSA-6x92-7v65-7m3r, UBUNTU-CVE-2026-41073

## What is CVE-2026-41073?

CVE-2026-41073 is a medium-severity vulnerability in bestpractical rt, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions prior to 5.0.10 and 6.0.0 through 6.0.2 contain a spreadsheet (CSV/formula) injection vulnerability. User-controlled data in spreadsheet exports is not sanitized before being written to the output file, which can cause spreadsheet applications to interpret crafted values as formulas or macros when the file is opened. This issue has been fixed in versions 5.0.10 and 6.0.3. If developers are unable to upgrade immediately, they can temporarily work around this issue by avoiding opening exported RT spreadsheet files directly in spreadsheet applications when the data may contain untrusted user input.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2026-41073?


## How do I fix CVE-2026-41073?

Upgrade to a fixed version.

## Is CVE-2026-41073 being exploited?

There is no known exploitation of CVE-2026-41073 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41073 and fix it if it is affected.

What it is: CVE-2026-41073 is a medium-severity vulnerability in bestpractical rt, published on 22 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41073 in the wild and no public exploit code.

Affected product: bestpractical rt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41073/ (Markdown: https://insights.sbomify.com/CVE-2026-41073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41073
- OSV: https://osv.dev/vulnerability/CVE-2026-41073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41073/
Summaries are generated and may contain mistakes; the official description above is the record.
