# CVE-2026-41075: RT: SQL injection via entry_aggregator parameter in JSON search

> Authenticated users can exploit SQL injection in RT to read or modify database data, requiring an upgrade to patched versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 28 May 2026
- **Also known as:** DEBIAN-CVE-2026-41075, GHSA-7vf8-xv7w-97c6, UBUNTU-CVE-2026-41075

## What is CVE-2026-41075?

CVE-2026-41075 is a high-severity SQL injection vulnerability in bestpractical rt, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 5.0.0 through 5.0.9 and 6.0.0 through 6.0.2 contain an SQL injection vulnerability. An authenticated user can craft input that is incorporated into database queries without proper validation, potentially allowing them to read or modify data in the RT database. This issue has been fixed in versions 5.0.10 and 6.0.3. If developers are unable to upgrade immediately, they can temporarily work around this issue by restricting RT account access to trusted users.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-41075?


## How do I fix CVE-2026-41075?

Upgrade to a fixed version.

## Is CVE-2026-41075 being exploited?

There is no known exploitation of CVE-2026-41075 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41075 and fix it if it is affected.

What it is: CVE-2026-41075 is a high-severity SQL injection vulnerability in bestpractical rt, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41075 in the wild and no public exploit code.

Affected product: bestpractical rt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41075/ (Markdown: https://insights.sbomify.com/CVE-2026-41075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41075
- OSV: https://osv.dev/vulnerability/CVE-2026-41075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41075/
Summaries are generated and may contain mistakes; the official description above is the record.
