# CVE-2026-41079: OpenPrinting CUPS: Heap out-of-bounds read in SNMP supply-level polling leaks stack memory to authenticated users

> A network-adjacent attacker can leak stack memory to authenticated users via crafted SNMP responses in CUPS, exposing sensitive data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 25 Apr 2026
- **Also known as:** AZL-83627, CLSA-2026-1777545654, CLSA-2026-1778234216, DEBIAN-CVE-2026-41079, ECHO-8222-9154-2d64, GHSA-6wpw-g8g6-wvrv, OESA-2026-2197, ROOT-OS-DEBIAN-12-CVE-2026-41079, ROOT-OS-DEBIAN-13-CVE-2026-41079, SUSE-SU-2026:4447-1, UBUNTU-CVE-2026-41079, openSUSE-SU-2026:10820-1

## What is CVE-2026-41079?

CVE-2026-41079 is a medium-severity vulnerability in OpenPrinting cups, published on 24 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to 2.4.17, a network-adjacent attacker can send a crafted SNMP response to the CUPS SNMP backend that causes an out-of-bounds read of up to 176 bytes past a stack buffer. The leaked memory is converted from UTF-16 to UTF-8 and stored as printer supply description strings, which are subsequently visible to authenticated users via IPP Get-Printer-Attributes responses and the CUPS web interface. This vulnerability is fixed in 2.4.17.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-41079?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cups` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 1.7.5-20.73.1 |
| `cups` | openSUSE:Tumbleweed | All versions | 2.4.19-2.1 |

Products: Openprinting Cups.

## How do I fix CVE-2026-41079?

Upgrade to a fixed version.

## Is CVE-2026-41079 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41079 exists.

## Other vulnerabilities in OpenPrinting cups

- [CVE-2025-58060](https://insights.sbomify.com/CVE-2025-58060/): cups has Authentication bypass with AuthType Negotiate (high 8.0)
- [CVE-2026-34978](https://insights.sbomify.com/CVE-2026-34978/): Path traversal in cups (medium 6.5)
- [CVE-2025-58364](https://insights.sbomify.com/CVE-2025-58364/): cups: Remote DoS via null dereference (medium 6.5)
- [CVE-2026-34980](https://insights.sbomify.com/CVE-2026-34980/): OpenPrinting CUPS: Shared PostScript queue lets anonymous Print-Job requests reach `lp` code execution over the network (medium 6.1)
- [CVE-2025-61915](https://insights.sbomify.com/CVE-2025-61915/): OpenPrinting CUPS vulnerable to stack based out-of-bound write (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41079 and fix it if it is affected.

What it is: CVE-2026-41079 is a medium-severity vulnerability in OpenPrinting cups, published on 24 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41079 exists.

Affected product: OpenPrinting cups. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41079/ (Markdown: https://insights.sbomify.com/CVE-2026-41079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41079
- OSV: https://osv.dev/vulnerability/CVE-2026-41079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41079/
Summaries are generated and may contain mistakes; the official description above is the record.
