# CVE-2026-41081: Apache Storm Client: Anonymous principal assigned on TLS client certificate verification failure

> Unauthenticated clients can bypass TLS authentication and gain anonymous access to Apache Storm services if authorization rules are permissive.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-j2q8-xx3q-8fqh

## What is CVE-2026-41081?

CVE-2026-41081 is a medium-severity authentication bypass vulnerability in Apache Storm Client, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Handling of TLS Client Authentication Failure Leading to Anonymous Principal Assignment in Apache Storm

Versions Affected: up to 2.8.7

Description: When TLS transport is enabled in Apache Storm without requiring client certificate authentication (the default configuration), the TlsTransportPlugin assigns a fallback principal (CN=ANONYMOUS) if no client certificate is presented or if certificate verification fails. The underlying SSLPeerUnverifiedException is caught and suppressed rather than rejecting the connection.

This fail-open behavior means an unauthenticated client can establish a TLS connection and receive a valid principal identity. If the configured authorizer (e.g., SimpleACLAuthorizer) does not explicitly deny access to CN=ANONYMOUS, this may result in unauthorized access to Storm services. The condition is logged at debug level only, reducing visibility in production.

Impact: Unauthenticated clients may be assigned a principal identity, potentially bypassing authorization in permissive or misconfigured environments.

Mitigation: Users should upgrade to 2.8.7 in which TLS authentication failures are handled in a fail-closed manner.

Users who cannot upgrade immediately should:
- Enable mandatory client certificate authentication (nimbus.thrift.tls.client.auth.required: true)
- Ensure authorization rules explicitly deny access to CN=ANONYMOUS
- Review all ACL configurations for implicit default-allow behavior

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-41081?

2 open source packages ship an affected version, including org.apache.storm:storm-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.storm:storm-client` | Maven | All versions | 2.8.7 |
| `org.apache.storm:storm-client` | Maven | All versions | 2.8.7 |

Products: Apache Storm.

## How do I fix CVE-2026-41081?

Upgrade org.apache.storm:storm-client to 2.8.7 or later.

## Is CVE-2026-41081 being exploited?

There is no known exploitation of CVE-2026-41081 in the wild and no public exploit code.

## Other vulnerabilities in Apache Storm Client

- [CVE-2021-38294](https://insights.sbomify.com/CVE-2021-38294/): Shell Command Injection Vulnerability in Nimbus Thrift Server (critical 9.8)
- [CVE-2021-40865](https://insights.sbomify.com/CVE-2021-40865/): Unsafe Pre-Authentication Deserialization In Workers (critical 9.8)
- [CVE-2018-11779](https://insights.sbomify.com/CVE-2018-11779/): Deserialization of Untrusted Data in Apache Storm (critical 9.8)
- [CVE-2015-3188](https://insights.sbomify.com/CVE-2015-3188/): Apache Storm remote code execution vulnerability (critical 9.8)
- [CVE-2026-35337](https://insights.sbomify.com/CVE-2026-35337/): Apache Storm Client: RCE through Unsafe Deserialization via Kerberos TGT Credential Handling (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41081 and fix it if it is affected.

What it is: CVE-2026-41081 is a medium-severity authentication bypass vulnerability in Apache Storm Client, published on 27 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41081 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.storm:storm-client (Maven): affected all versions; fixed in 2.8.7
- org.apache.storm:storm-client (Maven): affected all versions; fixed in 2.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41081/ (Markdown: https://insights.sbomify.com/CVE-2026-41081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41081
- OSV: https://osv.dev/vulnerability/CVE-2026-41081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41081/
Summaries are generated and may contain mistakes; the official description above is the record.
