# CVE-2026-41084: Apache Airflow: API authorization bypass: bulk TaskInstances allows cross-DAG mutation

> Authenticated users can bypass per-DAG authorization to mutate task instances in unauthorized DAGs via bulk API requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-airflow-2026-41084, CLEANSTART-2026-BM42810, ECHO-3377-ef85-9aed, GHSA-mxq5-f9c5-w4p5, MINI-pjm9-rpx7-57q7, PYSEC-2026-183

## What is CVE-2026-41084?

CVE-2026-41084 is a high-severity missing authorization vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A bug in Apache Airflow's bulk Task Instances API (`PATCH/DELETE /api/v2/dags/{dag_id}/dagRuns/{dag_run_id}/taskInstances`) evaluated authorization against the `dag_id` resolved from the URL path while operating on the `dag_id` / `dag_run_id` extracted from request-body entity fields. An authenticated UI/API user with edit permission on one Dag could mutate Task Instance state in any other Dag by keeping the authorized Dag's ID in the URL path and naming the target Dag's IDs in the request body entities. Affects deployments that rely on per-Dag edit-scope to keep Task Instance state isolated between teams. Users are advised to upgrade to `apache-airflow` 3.2.2 or later.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-41084?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `apache-airflow` | PyPI | From 3.2.0 | 3.2.2 |
| `airflow` | Bitnami | From 3.2.0 | 3.2.2 |

Products: Apache Airflow.

## How do I fix CVE-2026-41084?

Upgrade apache-airflow to 3.2.2 or later.

## Is CVE-2026-41084 being exploited?

There is no known exploitation of CVE-2026-41084 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41084 and fix it if it is affected.

What it is: CVE-2026-41084 is a high-severity missing authorization vulnerability in Apache Airflow, published on 1 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41084 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- apache-airflow (PyPI): affected from 3.2.0; fixed in 3.2.2
- airflow (Bitnami): affected from 3.2.0; fixed in 3.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41084/ (Markdown: https://insights.sbomify.com/CVE-2026-41084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41084
- OSV: https://osv.dev/vulnerability/CVE-2026-41084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41084/
Summaries are generated and may contain mistakes; the official description above is the record.
