# CVE-2026-41115: Apache Kafka: Improper Authorization in CONSUMER_GROUP_DESCRIBE API

> Misconfigured ACLs in Apache Kafka allow unauthorized users to access sensitive consumer group metadata due to documentation discrepancies regarding required permissions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** BIT-kafka-2026-41115, GHSA-p5r3-m3w4-4fj6, MINI-47f9-7442-wq3q, MINI-r8jv-vrwv-rf79

## What is CVE-2026-41115?

CVE-2026-41115 is a medium-severity missing authorization vulnerability in Apache Kafka, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An improper authorization vulnerability has been identified in Apache Kafka.

The implementation of the CONSUMER_GROUP_DESCRIBE (69) API validates the DESCRIBE operation on the GROUP resource instead of the READ operation that documented in the official kafka documentation and the KIP-848. This discrepancy can result in misconfigured Access Control Lists (ACLs) and unintended security postures, like granting READ permission to users who should not be able to join/sync groups, or allowing users without READ permission (but with DESCRIBE permission) to access sensitive group metadata.

The correct permission for CONSUMER_GROUP_DESCRIBE API is DESCRIBE GROUP so the current implementation is correct. However, the kafka documentation as well as the KIP-848 will be updated to reflect the correct permission. We advise the Kafka users to review existing group ACLs to ensure the principle of least privilege.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-41115?

1 open source package ship an affected version, including kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kafka` | Bitnami | From 4.0.0 | 4.3.1 |

Products: Apache Kafka.

## How do I fix CVE-2026-41115?

Upgrade kafka to 4.3.1 or later.

## Is CVE-2026-41115 being exploited?

There is no known exploitation of CVE-2026-41115 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41115 and fix it if it is affected.

What it is: CVE-2026-41115 is a medium-severity missing authorization vulnerability in Apache Kafka, published on 2 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41115 in the wild and no public exploit code.

Affected packages and fixed versions:
- kafka (Bitnami): affected from 4.0.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41115/ (Markdown: https://insights.sbomify.com/CVE-2026-41115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41115
- OSV: https://osv.dev/vulnerability/CVE-2026-41115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41115/
Summaries are generated and may contain mistakes; the official description above is the record.
