# CVE-2026-41128: Craft CMS has a Missing Authorization Check on User Group Removal via save-permissions Action

> Attackers with viewUsers permission can remove arbitrary users from all groups due to missing authorization checks in the save-permissions action.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-jq2f-59pj-p3m3

## What is CVE-2026-41128?

CVE-2026-41128 is a medium-severity missing authorization vulnerability in craftcms cms, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). In versions 5.6.0 through 5.9.14, the `actionSavePermissions()` endpoint allows a user with only `viewUsers` permission to remove arbitrary users from all user groups. While `_saveUserGroups()` enforces per-group authorization for additions, it performs no equivalent authorization check for removals, so submitting an empty `groups` value removes all existing group memberships. Version 5.9.15 contains a patch.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-41128?

2 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 5.6.0 | 5.9.15 |
| `craftcms/cms` | Packagist | From 5.6.0 | 5.9.15 |

## How do I fix CVE-2026-41128?

Upgrade craftcms/cms to 5.9.15 or later.

## Is CVE-2026-41128 being exploited?

There is no known exploitation of CVE-2026-41128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41128 and fix it if it is affected.

What it is: CVE-2026-41128 is a medium-severity missing authorization vulnerability in craftcms cms, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41128 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 5.6.0; fixed in 5.9.15
- craftcms/cms (Packagist): affected from 5.6.0; fixed in 5.9.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41128/ (Markdown: https://insights.sbomify.com/CVE-2026-41128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41128
- OSV: https://osv.dev/vulnerability/CVE-2026-41128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41128/
Summaries are generated and may contain mistakes; the official description above is the record.
