# CVE-2026-41131: OpenFGA has Improper Policy Enforcement

> Attackers can bypass authorization checks in OpenFGA when caching is enabled and conditions are used, potentially gaining unauthorized access.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-57j5-qwp2-vqp6, GO-2026-5136, MINI-2vm4-ccq9-h7mm, MINI-78ph-vfw2-478p, MINI-7xv4-wjhr-659v, MINI-c6qc-58c7-285j, MINI-cmc8-wj27-7qw3, MINI-cvm8-v5r3-c6x6, MINI-g262-wvc7-8ch5, MINI-gpfj-mm74-6gvc, MINI-hfxw-9wpp-2m9q, MINI-hjv2-4c5h-55xc, MINI-j6rh-h8qp-qq88, MINI-pcx5-4r3x-r8xc, MINI-pm8p-jrrw-4c3w, MINI-pq4h-gh97-h3m3, MINI-qvrx-3m25-9jc8, MINI-rc89-6xwm-qcp9, MINI-rmhg-p38v-xxr6, MINI-xcr3-wxxv-3fjh

## What is CVE-2026-41131?

CVE-2026-41131 is a medium-severity missing authorization vulnerability in openfga, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is an authorization/permission engine built for developers. Prior to version 1.14.1, in specific scenarios, models using conditions with caching enabled can result in two different check requests producing the same cache key. This could result in OpenFGA reusing an earlier cached result for a subsequent request. The preconditions for vulnerability are the model having relations which rely on condition evaluation and the user having caching enabled. OpenFGA v1.14.1 contains a fix.

Weakness: CWE-863 (Incorrect Authorization), CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2026-41131?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.14.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.14.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.14.1 |

Products: Openfga Helm Charts, Openfga Openfga.

## How do I fix CVE-2026-41131?

Upgrade github.com/openfga/openfga to 1.14.1 or later.

## Is CVE-2026-41131 being exploited?

There is no known exploitation of CVE-2026-41131 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2026-55689](https://insights.sbomify.com/CVE-2026-55689/): OpenFGA: OIDC audience validation skipped when --authn-oidc-audience is unset (medium 6.8)
- [CVE-2026-24851](https://insights.sbomify.com/CVE-2026-24851/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-64751](https://insights.sbomify.com/CVE-2025-64751/): OpenFGA Improper Policy Enforcement (medium 5.8)
- [CVE-2025-55213](https://insights.sbomify.com/CVE-2025-55213/): OpenFGA Authorization Bypass (Check) (medium 5.8)
- [CVE-2025-48371](https://insights.sbomify.com/CVE-2025-48371/): OpenFGA Authorization Bypass (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41131 and fix it if it is affected.

What it is: CVE-2026-41131 is a medium-severity missing authorization vulnerability in openfga, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41131 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.14.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.14.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41131/ (Markdown: https://insights.sbomify.com/CVE-2026-41131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41131
- OSV: https://osv.dev/vulnerability/CVE-2026-41131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41131/
Summaries are generated and may contain mistakes; the official description above is the record.
