# CVE-2026-41135: free5GC PCF: Memory Leak via CORS Middleware Registration in HTTP Handler Leads to Denial of Service

> Unauthenticated attackers can cause memory exhaustion and denial of service in free5GC PCF by sending repeated HTTP requests to the OAM endpoint.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-98cp-84m9-q3qp, GO-2026-5278

## What is CVE-2026-41135?

CVE-2026-41135 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC UDR is the Policy Control Function (PCF) for free5GC, an an open-source project for 5th generation (5G) mobile core networks. A memory leak vulnerability in versions prior to 1.4.3 allows any unauthenticated attacker with network access to the PCF SBI interface to cause uncontrolled memory growth by sending repeated HTTP requests to the OAM endpoint. The root cause is a `router.Use()` call inside an HTTP handler that registers a new CORS middleware on every incoming request, permanently growing the Gin router's handler chain. This leads to progressive memory exhaustion and eventual Denial of Service of the PCF, preventing all UEs from obtaining AM and SM policies and blocking 5G session establishment. Version 1.4.3 contains a patch.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-41135?

3 open source packages ship an affected version, including github.com/free5gc/pcf. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |

Products: Free5gc Free5gc, Free5gc Pcf.

## How do I fix CVE-2026-41135?

Upgrade github.com/free5gc/pcf to 1.4.3 or later.

## Is CVE-2026-41135 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41135 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41135 and fix it if it is affected.

What it is: CVE-2026-41135 is a high-severity denial of service vulnerability in Free5gc Free5gc, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41135 exists.

Affected packages and fixed versions:
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41135/ (Markdown: https://insights.sbomify.com/CVE-2026-41135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41135
- OSV: https://osv.dev/vulnerability/CVE-2026-41135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41135/
Summaries are generated and may contain mistakes; the official description above is the record.
