{"answers":{"affected":"3 open source packages ship an affected version, including poetry.","exploited":"There is no known exploitation of CVE-2026-41140 in the wild and no public exploit code.","fix":"Upgrade poetry to 2.3.4 or later.","what":"CVE-2026-41140 is a low-severity path traversal vulnerability in python-poetry poetry, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41140 and fix it if it is affected.\n\nWhat it is: CVE-2026-41140 is a low-severity path traversal vulnerability in python-poetry poetry, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41140 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- poetry (PyPI): affected all versions; fixed in 2.3.4\n- poetry (PyPI): affected all versions; fixed in 2.3.4\n- poetry (PyPI): affected all versions; fixed in 2.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41140/ (Markdown: https://insights.sbomify.com/CVE-2026-41140/index.md)","id":"CVE-2026-41140","markdown":"https://insights.sbomify.com/CVE-2026-41140/index.md","name":"CVE-2026-41140","record":{"aliases":["AZL-84035","DEBIAN-CVE-2026-41140","GHSA-73h3-mf4w-8647","MINI-fg5x-hfh7-2v7w","PYSEC-2026-2890","ROOT-APP-PYPI-CVE-2026-41140","UBUNTU-CVE-2026-41140"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python dependency manager","requires_auth":"none","summary":"Attackers can exploit path traversal in Poetry's tar extraction to write files outside the intended directory, potentially leading to code execution.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":0.6,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions where tarfile.data_filter is unavailable. Considering only Python versions which are still supported by Poetry, these are 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4. This vulnerability is fixed in 2.3.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Poetry: Path traversal in tar extraction on Python 3.10.0 - 3.10.12 and 3.11.0 - 3.11.4","id":"CVE-2026-41140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"EspoCRM: IDOR in EmailTemplate Prepare Endpoint Leaks Entity Data via Email Address Lookup","id":"CVE-2026-41141"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":null,"source":"GHSA-73h3-mf4w-8647"},{"ecosystem":"PyPI","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":"pkg:pypi/poetry","source":"GHSA-73h3-mf4w-8647"},{"ecosystem":"PyPI","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"poetry","purl":"pkg:pypi/poetry","source":"PYSEC-2026-2890"}],"prev":{"headline":"Unsafe array index getter in mathjs","id":"CVE-2026-41139"},"products":["poetry"],"published":"2026-04-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["python-poetry"]},"summary":"Attackers can exploit path traversal in Poetry's tar extraction to write files outside the intended directory, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2026-41140/"}