{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41143 exists.","fix":"Upgrade yeswiki/yeswiki to 4.6.1 or later.","what":"CVE-2026-41143 is a high-severity SQL injection vulnerability in yeswiki, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41143 and fix it if it is affected.\n\nWhat it is: CVE-2026-41143 is a high-severity SQL injection vulnerability in yeswiki, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41143 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.1\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.6.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41143/ (Markdown: https://insights.sbomify.com/CVE-2026-41143/index.md)","id":"CVE-2026-41143","markdown":"https://insights.sbomify.com/CVE-2026-41143/index.md","name":"CVE-2026-41143","record":{"aliases":["GHSA-f58v-p6j9-24c2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki wiki system","requires_auth":"low_privilege","summary":"An authenticated attacker can execute arbitrary SQL commands via the id_fiche parameter in the Bazar module, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"YesWiki is a wiki system written in PHP. Prior to version 4.6.1, YesWiki bazar module contains a SQL injection vulnerability in tools/bazar/services/EntryManager.php at line 704. The $data['id_fiche'] value (sourced from $_POST['id_fiche']) is concatenated directly into a raw SQL query without any sanitization or parameterization. This issue has been patched in version 4.6.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki vulnerable to authenticated SQL Injection via id_fiche in EntryManager::formatDataBeforeSave()","id":"CVE-2026-41143","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"F´ (F Prime) has Integer Overflow in FileUplink","id":"CVE-2026-41144"},"packages":[{"ecosystem":"Packagist","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-f58v-p6j9-24c2"},{"ecosystem":"Packagist","fixed":["4.6.1"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-f58v-p6j9-24c2"}],"prev":{"headline":"OpenEXR is Vulnerable to Integer overflow in ImageChannel::resize leads to heap OOB write via OpenEXRUtil public API","id":"CVE-2026-41142"},"products":["yeswiki"],"published":"2026-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-07","vendors":["YesWiki"]},"summary":"An authenticated attacker can execute arbitrary SQL commands via the id_fiche parameter in the Bazar module, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2026-41143/"}