CVE-2026-41148 Mermaid: Improper sanitization of `classDefs` in diagrams leads to CSS injection
Attackers can inject malicious CSS via classDef values in Mermaid diagrams, enabling page defacement, user tracking, and DOM attribute exfiltration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-41148?
CVE-2026-41148 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and prior, in addition to 11.0.0-alpha.1 through 11.12.0 are vulnerable to CSS injection through improper sanitization. The state diagram (and any other diagram type that routes user-controlled style strings through the createCssStyles parser) captures classDef values using an unrestricted regex that matches everything up to a newline. That value then flows unsanitized through addStyleClass() into createCssStyles() and is assigned to style.innerHTML, so a closing brace (}) in the value terminates the generated CSS selector and turns everything after it into a new CSS rule on the page. This enables page defacement, user tracking via url() callbacks, and DOM attribute exfiltration. This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.
Weakness: CWE-94
Which versions are affected by CVE-2026-41148?
4 open source packages ship an affected version, including mermaid.
| Package | Affected | Fixed in |
|---|---|---|
mermaid npm | All versions | 10.9.6 |
mermaid npm | All versions | 10.9.6 |
mermaid npm | From 11.0.0-alpha.1 | 11.15.0 |
mermaid npm | From 11.0.0-alpha.1 | 11.15.0 |
How do I fix CVE-2026-41148?
Upgrade mermaid to a fixed version for your release line: 10.9.6 or 11.15.0.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-41148 being exploited?
There is no known exploitation of CVE-2026-41148 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-41148, GHSA-xcj9-5m2h-648r, MINI-hg26-fchg-r9q7, MINI-mr8r-fjhr-xmxx, UBUNTU-CVE-2026-41148.