{"answers":{"affected":"4 open source packages ship an affected version, including mermaid.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41149 exists.","fix":"Upgrade mermaid to a fixed version for your release line: 10.9.6 or 11.15.0.","what":"CVE-2026-41149 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41149 and fix it if it is affected.\n\nWhat it is: CVE-2026-41149 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41149 exists.\n\nAffected packages and fixed versions:\n- mermaid (npm): affected all versions; fixed in 10.9.6\n- mermaid (npm): affected all versions; fixed in 10.9.6\n- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0\n- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41149/ (Markdown: https://insights.sbomify.com/CVE-2026-41149/index.md)","id":"CVE-2026-41149","markdown":"https://insights.sbomify.com/CVE-2026-41149/index.md","name":"CVE-2026-41149","record":{"aliases":["DEBIAN-CVE-2026-41149","GHSA-ghcm-xqfw-q4vr","MINI-64cw-chmx-8v92","MINI-vmjx-p29h-w3q2","UBUNTU-CVE-2026-41149"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diagramming library","requires_auth":"none","summary":"Attackers can inject HTML into Mermaid state diagrams via classDef, potentially leading to code execution or security bypasses in applications using the library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and earlier, as well as 11.0.0-alpha.1 through 11.14.0, are vulnerable to HTML injection under the default configuration. Specifically, the classDef directive in Mermaid state diagrams permits DOM injection that escapes the SVG context. However, \u003cscript\u003e tags are stripped, which prevents cross-site scripting (XSS). This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting \"securityLevel\": \"sandbox\", which prevents the issue by rendering the mermaid diagram in a sandboxed \u003ciframe\u003e.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Mermaid: Improper sanitization of `classDef` in state diagrams leads to HTML injection","id":"CVE-2026-41149","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":3,"next":{"headline":"Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS","id":"CVE-2026-41150"},"packages":[{"ecosystem":"npm","fixed":["10.9.6"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-ghcm-xqfw-q4vr"},{"ecosystem":"npm","fixed":["10.9.6"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-ghcm-xqfw-q4vr"},{"ecosystem":"npm","fixed":["11.15.0"],"introduced":["11.0.0-alpha.1"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-ghcm-xqfw-q4vr"},{"ecosystem":"npm","fixed":["11.15.0"],"introduced":["11.0.0-alpha.1"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-ghcm-xqfw-q4vr"}],"prev":{"headline":"Mermaid: Improper sanitization of `classDefs` in diagrams leads to CSS injection","id":"CVE-2026-41148"},"products":["mermaid"],"published":"2026-05-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-23","vendors":["mermaid-js"]},"summary":"Attackers can inject HTML into Mermaid state diagrams via classDef, potentially leading to code execution or security bypasses in applications using the library.","url":"https://insights.sbomify.com/CVE-2026-41149/"}