# CVE-2026-41149: Mermaid: Improper sanitization of `classDef` in state diagrams leads to HTML injection

> Attackers can inject HTML into Mermaid state diagrams via classDef, potentially leading to code execution or security bypasses in applications using the library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2026
- **Updated:** 23 May 2026
- **Also known as:** DEBIAN-CVE-2026-41149, GHSA-ghcm-xqfw-q4vr, MINI-64cw-chmx-8v92, MINI-vmjx-p29h-w3q2, UBUNTU-CVE-2026-41149

## What is CVE-2026-41149?

CVE-2026-41149 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Versions 10.9.5 and earlier, as well as 11.0.0-alpha.1 through 11.14.0, are vulnerable to HTML injection under the default configuration. Specifically, the classDef directive in Mermaid state diagrams permits DOM injection that escapes the SVG context. However, <script> tags are stripped, which prevents cross-site scripting (XSS). This issue has been fixed in versions 10.9.6 and 11.15.0. If developers are unable to immediately upgrade, they can work around this issue by setting "securityLevel": "sandbox", which prevents the issue by rendering the mermaid diagram in a sandboxed <iframe>.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-41149?

4 open source packages ship an affected version, including mermaid.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |

## How do I fix CVE-2026-41149?

Upgrade mermaid to a fixed version for your release line: 10.9.6 or 11.15.0.

## Is CVE-2026-41149 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41149 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41149 and fix it if it is affected.

What it is: CVE-2026-41149 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 22 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41149 exists.

Affected packages and fixed versions:
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41149/ (Markdown: https://insights.sbomify.com/CVE-2026-41149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41149
- OSV: https://osv.dev/vulnerability/CVE-2026-41149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41149/
Summaries are generated and may contain mistakes; the official description above is the record.
