# CVE-2026-41150: Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS

> An attacker can cause a denial of service in Mermaid by crafting a Gantt chart that triggers an infinite loop during rendering.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** DEBIAN-CVE-2026-41150, GHSA-6m6c-36f7-fhxh, MINI-53mm-55gm-wj49, MINI-mm89-8xhw-wm72, UBUNTU-CVE-2026-41150

## What is CVE-2026-41150?

CVE-2026-41150 is a medium-severity denial of service vulnerability in mermaid-js mermaid, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.6 and 11.15.0, there is a denial-of-service attack when rendering gantt charts, if they use the excludes attribute to exclude all dates. mermaid.parse is unaffected, unless you then call the ganttDb.getTasks() (which is called when rendering a diagram). This vulnerability is fixed in 10.9.6 and 11.15.0.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2026-41150?

4 open source packages ship an affected version, including mermaid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |

Products: Mermaid Project Mermaid.

## How do I fix CVE-2026-41150?

Upgrade mermaid to a fixed version for your release line: 10.9.6 or 11.15.0.

## Is CVE-2026-41150 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41150 exists.

## Other vulnerabilities in mermaid-js mermaid

- [CVE-2021-43861](https://insights.sbomify.com/CVE-2021-43861/): Incorrect sanitisation function leads to `XSS` (high 7.2)
- [CVE-2021-35513](https://insights.sbomify.com/CVE-2021-35513/): Cross-site Scripting in Mermaid (medium 6.1)
- [CVE-2026-41159](https://insights.sbomify.com/CVE-2026-41159/): Mermaid: Improper sanitization of configuration leads to CSS injection (medium 5.3)
- [CVE-2025-54880](https://insights.sbomify.com/CVE-2025-54880/): Mermaid does not properly sanitize architecture diagram iconText leading to XSS (medium 5.1)
- [CVE-2022-31108](https://insights.sbomify.com/CVE-2022-31108/): Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41150 and fix it if it is affected.

What it is: CVE-2026-41150 is a medium-severity denial of service vulnerability in mermaid-js mermaid, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41150 exists.

Affected packages and fixed versions:
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41150/ (Markdown: https://insights.sbomify.com/CVE-2026-41150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41150
- OSV: https://osv.dev/vulnerability/CVE-2026-41150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41150/
Summaries are generated and may contain mistakes; the official description above is the record.
