# CVE-2026-41159: Mermaid: Improper sanitization of configuration leads to CSS injection

> Attackers can inject CSS to deface pages and exfiltrate DOM attributes via Mermaid configuration options, affecting applications using the library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 1 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-41159, GHSA-87f9-hvmw-gh4p, MINI-686p-c639-hg28, MINI-hpvg-h3xp-x3jg, UBUNTU-CVE-2026-41159

## What is CVE-2026-41159?

CVE-2026-41159 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.6 and 11.15.0,  Mermaid's default configuration allows injecting CSS that applies outside of the Mermaid diagram via the fontFamily, themeCSS, and altFontFamily configuration options. The injected CSS exploits stylis's & (scope reference) handling. :not(&) escapes the #mermaid-xxx automatic scoping, applying styles to all page elements. Global at-rules (@font-face, @keyframes, @counter-style) are also injectable as stylis hoists them to top level. This allows page defacement and DOM attribute exfiltration via CSS :has() selectors. This vulnerability is fixed in 10.9.6 and 11.15.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-41159?

4 open source packages ship an affected version, including mermaid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | All versions | 10.9.6 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |
| `mermaid` | npm | From 11.0.0-alpha.1 | 11.15.0 |

Products: Mermaid Project Mermaid.

## How do I fix CVE-2026-41159?

Upgrade mermaid to a fixed version for your release line: 10.9.6 or 11.15.0.

## Is CVE-2026-41159 being exploited?

There is no known exploitation of CVE-2026-41159 in the wild and no public exploit code.

## Other vulnerabilities in mermaid-js mermaid

- [CVE-2021-43861](https://insights.sbomify.com/CVE-2021-43861/): Incorrect sanitisation function leads to `XSS` (high 7.2)
- [CVE-2021-35513](https://insights.sbomify.com/CVE-2021-35513/): Cross-site Scripting in Mermaid (medium 6.1)
- [CVE-2026-41150](https://insights.sbomify.com/CVE-2026-41150/): Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS (medium 5.3)
- [CVE-2025-54880](https://insights.sbomify.com/CVE-2025-54880/): Mermaid does not properly sanitize architecture diagram iconText leading to XSS (medium 5.1)
- [CVE-2022-31108](https://insights.sbomify.com/CVE-2022-31108/): Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41159 and fix it if it is affected.

What it is: CVE-2026-41159 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 29 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41159 in the wild and no public exploit code.

Affected packages and fixed versions:
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected all versions; fixed in 10.9.6
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0
- mermaid (npm): affected from 11.0.0-alpha.1; fixed in 11.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41159/ (Markdown: https://insights.sbomify.com/CVE-2026-41159/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41159
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41159
- OSV: https://osv.dev/vulnerability/CVE-2026-41159

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41159/
Summaries are generated and may contain mistakes; the official description above is the record.
