# CVE-2026-41161: Username Enumeration via Timing Attack

> Unauthenticated attackers can enumerate valid usernames by measuring response times on the login endpoint, exposing user account existence.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-43fj-qp3h-hrh5

## What is CVE-2026-41161?

CVE-2026-41161 is a medium-severity vulnerability in Sync-in server, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sync-in Server is a secure, open-source platform for file storage, sharing, collaboration, and syncing. Prior to version 2.2.0, the /api/auth/login endpoint contains a logic flaw that allows unauthenticated remote attackers to enumerate valid usernames by measuring the application's response time. This issue has been patched in version 2.2.0.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-41161?

2 open source packages ship an affected version, including @sync-in/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sync-in/server` | npm | All versions | 2.2.0 |
| `@sync-in/server` | npm | All versions | 2.2.0 |

Products: Sync-in Sync-in Server.

## How do I fix CVE-2026-41161?

Upgrade @sync-in/server to 2.2.0 or later.

## Is CVE-2026-41161 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41161 exists.

## Other vulnerabilities in Sync-in server

- [CVE-2025-67438](https://insights.sbomify.com/CVE-2025-67438/): Sync-in Server has a stored cross-site scripting (XSS) vulnerability (medium 6.1)
- [CVE-2025-56869](https://insights.sbomify.com/CVE-2025-56869/): Path traversal in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41161 and fix it if it is affected.

What it is: CVE-2026-41161 is a medium-severity vulnerability in Sync-in server, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41161 exists.

Affected packages and fixed versions:
- @sync-in/server (npm): affected all versions; fixed in 2.2.0
- @sync-in/server (npm): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41161/ (Markdown: https://insights.sbomify.com/CVE-2026-41161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41161
- OSV: https://osv.dev/vulnerability/CVE-2026-41161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41161/
Summaries are generated and may contain mistakes; the official description above is the record.
