CVE-2026-41163 bubblewrap vulnerable to privilege escalation in setuid mode via ptrace
Attackers can escalate privileges by using ptrace to control sandbox setup in setuid mode, allowing unauthorized overlay mounts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-41163?
CVE-2026-41163 is a high-severity vulnerability in containers bubblewrap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.
Weakness: CWE-269
Which versions are affected by CVE-2026-41163?
Linux distribution packages (2)
bubblewrap Red Hat:hummingbird:1 | All versions | 0:0.12.0-1.hum1 |
bubblewrap openSUSE:Tumbleweed | All versions | 0.11.2-1.1 |
How do I fix CVE-2026-41163?
Upgrade to a fixed version.
Is CVE-2026-41163 being exploited?
There is no known exploitation of CVE-2026-41163 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-41163, GHSA-xq78-7hw4-5jvp, RHSA-2026:60368, SUSE-SU-2026:2094-1, SUSE-SU-2026:21847-1, UBUNTU-CVE-2026-41163 and 3 more.