{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-41163 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-41163 is a high-severity vulnerability in containers bubblewrap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41163 and fix it if it is affected.\n\nWhat it is: CVE-2026-41163 is a high-severity vulnerability in containers bubblewrap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-41163 in the wild and no public exploit code.\n\nAffected product: containers bubblewrap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41163/ (Markdown: https://insights.sbomify.com/CVE-2026-41163/index.md)","id":"CVE-2026-41163","markdown":"https://insights.sbomify.com/CVE-2026-41163/index.md","name":"CVE-2026-41163","record":{"aliases":["DEBIAN-CVE-2026-41163","GHSA-xq78-7hw4-5jvp","RHSA-2026:60368","SUSE-SU-2026:2094-1","SUSE-SU-2026:21847-1","UBUNTU-CVE-2026-41163","USN-8288-1","openSUSE-SU-2026:10671-1","openSUSE-SU-2026:20811-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Linux sandboxing tool","requires_auth":"none","summary":"Attackers can escalate privileges by using ptrace to control sandbox setup in setuid mode, allowing unauthorized overlay mounts.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the \"overlay mount\" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.","ecosystems":["Red Hat:hummingbird:1","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"bubblewrap vulnerable to privilege escalation in setuid mode via ptrace","id":"CVE-2026-41163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"nuts-node: JWT type confusion in v1 access token introspection allows VP replay as access token","id":"CVE-2026-41164"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:0.12.0-1.hum1"],"introduced":["0"],"last_affected":[],"package":"bubblewrap","purl":"pkg:rpm/redhat/bubblewrap","source":"RHSA-2026:60368"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.11.2-1.1"],"introduced":["0"],"last_affected":[],"package":"bubblewrap","purl":"pkg:rpm/opensuse/bubblewrap\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10671-1"}],"prev":{"headline":"Username Enumeration via Timing Attack","id":"CVE-2026-41161"},"products":["bubblewrap"],"published":"2026-05-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-01","vendors":["containers"]},"summary":"Attackers can escalate privileges by using ptrace to control sandbox setup in setuid mode, allowing unauthorized overlay mounts.","url":"https://insights.sbomify.com/CVE-2026-41163/"}