# CVE-2026-41163: bubblewrap vulnerable to privilege escalation in setuid mode via ptrace

> Attackers can escalate privileges by using ptrace to control sandbox setup in setuid mode, allowing unauthorized overlay mounts.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2026
- **Updated:** 1 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-41163, GHSA-xq78-7hw4-5jvp, RHSA-2026:60368, SUSE-SU-2026:2094-1, SUSE-SU-2026:21847-1, UBUNTU-CVE-2026-41163, USN-8288-1, openSUSE-SU-2026:10671-1, openSUSE-SU-2026:20811-1

## What is CVE-2026-41163?

CVE-2026-41163 is a high-severity vulnerability in containers bubblewrap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-41163?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bubblewrap` | Red Hat:hummingbird:1 | All versions | 0:0.12.0-1.hum1 |
| `bubblewrap` | openSUSE:Tumbleweed | All versions | 0.11.2-1.1 |

## How do I fix CVE-2026-41163?

Upgrade to a fixed version.

## Is CVE-2026-41163 being exploited?

There is no known exploitation of CVE-2026-41163 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41163 and fix it if it is affected.

What it is: CVE-2026-41163 is a high-severity vulnerability in containers bubblewrap, published on 9 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41163 in the wild and no public exploit code.

Affected product: containers bubblewrap. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41163/ (Markdown: https://insights.sbomify.com/CVE-2026-41163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41163
- OSV: https://osv.dev/vulnerability/CVE-2026-41163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41163/
Summaries are generated and may contain mistakes; the official description above is the record.
