# CVE-2026-41175: Statamic: Unsafe method invocation via query value resolution allows data destruction

> Attackers can destroy content, assets, and user accounts via unsafe method invocation in query parameters or API arguments.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-4jjr-vmv7-wh4w

## What is CVE-2026-41175?

CVE-2026-41175 is a high-severity code injection vulnerability in statamic cms, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Statamic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.20 and 6.13.0, manipulating query parameters on Control Panel and REST API endpoints, or arguments in GraphQL queries, could result in the loss of content, assets, and user accounts. The Control Panel requires authentication with minimal permissions in order to exploit. e.g. "view entries" permission to delete entries, or "view users" permission to delete users, etc. The REST and GraphQL API exploits do not require any permissions, however neither are enabled by default. In order to be exploited, they would need to be explicitly enabled with no authentication configured, and the specific resources enabled too. Sites that enable the REST or GraphQL API without authentication should treat patching as critical priority. This has been fixed in 5.73.20 and 6.13.0.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-41175?

4 open source packages ship an affected version, including statamic/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `statamic/cms` | Packagist | All versions | 5.73.20 |
| `statamic/cms` | Packagist | All versions | 5.73.20 |
| `statamic/cms` | Packagist | From 6.0.0-alpha.1 | 6.13.0 |
| `statamic/cms` | Packagist | From 6.0.0-alpha.1 | 6.13.0 |

Products: Statamic Statamic.

## How do I fix CVE-2026-41175?

Upgrade statamic/cms to a fixed version for your release line: 5.73.20 or 6.13.0.

## Is CVE-2026-41175 being exploited?

There is no known exploitation of CVE-2026-41175 in the wild and no public exploit code.

## Other vulnerabilities in statamic cms

- [CVE-2021-45364](https://insights.sbomify.com/CVE-2021-45364/): Code injection in n/a (critical 9.8)
- [CVE-2026-27593](https://insights.sbomify.com/CVE-2026-27593/): Statamic is vulnerable to account takeover via password reset link injection (critical 9.3)
- [CVE-2026-27939](https://insights.sbomify.com/CVE-2026-27939/): Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass (high 8.8)
- [CVE-2023-48217](https://insights.sbomify.com/CVE-2023-48217/): Remote code execution via form uploads in statamic/cms (high 8.8)
- [CVE-2017-11422](https://insights.sbomify.com/CVE-2017-11422/): Statamic framework Incorrect Permission Assignment (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41175 and fix it if it is affected.

What it is: CVE-2026-41175 is a high-severity code injection vulnerability in statamic cms, published on 22 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41175 in the wild and no public exploit code.

Affected packages and fixed versions:
- statamic/cms (Packagist): affected all versions; fixed in 5.73.20
- statamic/cms (Packagist): affected all versions; fixed in 5.73.20
- statamic/cms (Packagist): affected from 6.0.0-alpha.1; fixed in 6.13.0
- statamic/cms (Packagist): affected from 6.0.0-alpha.1; fixed in 6.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41175/ (Markdown: https://insights.sbomify.com/CVE-2026-41175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41175
- OSV: https://osv.dev/vulnerability/CVE-2026-41175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41175/
Summaries are generated and may contain mistakes; the official description above is the record.
