{"answers":{"affected":"2 open source packages ship an affected version, including psitransfer.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41180 exists.","fix":"Upgrade psitransfer to 2.4.3 or later.","what":"CVE-2026-41180 is a high-severity path traversal vulnerability in psi-4ward psitransfer, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41180 and fix it if it is affected.\n\nWhat it is: CVE-2026-41180 is a high-severity path traversal vulnerability in psi-4ward psitransfer, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41180 exists.\n\nAffected packages and fixed versions:\n- psitransfer (npm): affected all versions; fixed in 2.4.3\n- psitransfer (npm): affected all versions; fixed in 2.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41180/ (Markdown: https://insights.sbomify.com/CVE-2026-41180/index.md)","id":"CVE-2026-41180","markdown":"https://insights.sbomify.com/CVE-2026-41180/index.md","name":"CVE-2026-41180","record":{"aliases":["GHSA-533q-w4g6-5586"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PsiTransfer file sharing","requires_auth":"none","summary":"An unauthenticated attacker can exploit a path traversal flaw to write malicious config files, leading to code execution on restart in specific custom directory configurations.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.4.3, the upload PATCH flow under `/files/:uploadId` validates the mounted request path using the still-encoded `req.path`, but the downstream tus handler later writes using the decoded `req.params.uploadId`. In deployments that use a supported custom `PSITRANSFER_UPLOAD_DIR` whose basename prefixes a startup-loaded JavaScript path, such as `conf`, an unauthenticated attacker can create `config.\u003cNODE_ENV\u003e.js` in the application root. The attacker-controlled file is then executed on the next process restart. Version 2.4.3 contains a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PsiTransfer: Upload PATCH path traversal can create `config.\u003cNODE_ENV\u003e.js` and lead to code execution on restart","id":"CVE-2026-41180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Traefik: Errors middleware forwards Authorization and Cookie headers to separate error page service","id":"CVE-2026-41181"},"packages":[{"ecosystem":"npm","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"psitransfer","purl":null,"source":"GHSA-533q-w4g6-5586"},{"ecosystem":"npm","fixed":["2.4.3"],"introduced":["0"],"last_affected":[],"package":"psitransfer","purl":"pkg:npm/psitransfer","source":"GHSA-533q-w4g6-5586"}],"prev":{"headline":"RClone: Unauthenticated operations/fsinfo allows attacker-controlled backend instantiation and local command execution","id":"CVE-2026-41179"},"products":["psitransfer"],"published":"2026-04-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["psi-4ward"]},"summary":"An unauthenticated attacker can exploit a path traversal flaw to write malicious config files, leading to code execution on restart in specific custom directory configurations.","url":"https://insights.sbomify.com/CVE-2026-41180/"}