# CVE-2026-41180: PsiTransfer: Upload PATCH path traversal can create `config.<NODE_ENV>.js` and lead to code execution on restart

> An unauthenticated attacker can exploit a path traversal flaw to write malicious config files, leading to code execution on restart in specific custom directory configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-533q-w4g6-5586

## What is CVE-2026-41180?

CVE-2026-41180 is a high-severity path traversal vulnerability in psi-4ward psitransfer, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PsiTransfer is an open source, self-hosted file sharing solution. Prior to version 2.4.3, the upload PATCH flow under `/files/:uploadId` validates the mounted request path using the still-encoded `req.path`, but the downstream tus handler later writes using the decoded `req.params.uploadId`. In deployments that use a supported custom `PSITRANSFER_UPLOAD_DIR` whose basename prefixes a startup-loaded JavaScript path, such as `conf`, an unauthenticated attacker can create `config.<NODE_ENV>.js` in the application root. The attacker-controlled file is then executed on the next process restart. Version 2.4.3 contains a patch.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41180?

2 open source packages ship an affected version, including psitransfer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `psitransfer` | npm | All versions | 2.4.3 |
| `psitransfer` | npm | All versions | 2.4.3 |

## How do I fix CVE-2026-41180?

Upgrade psitransfer to 2.4.3 or later.

## Is CVE-2026-41180 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41180 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41180 and fix it if it is affected.

What it is: CVE-2026-41180 is a high-severity path traversal vulnerability in psi-4ward psitransfer, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41180 exists.

Affected packages and fixed versions:
- psitransfer (npm): affected all versions; fixed in 2.4.3
- psitransfer (npm): affected all versions; fixed in 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41180/ (Markdown: https://insights.sbomify.com/CVE-2026-41180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41180
- OSV: https://osv.dev/vulnerability/CVE-2026-41180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41180/
Summaries are generated and may contain mistakes; the official description above is the record.
