# CVE-2026-41201: CI4MS: Backup Management Full Account Takeover for All-Roles & Privilege-Escalation via Stored DOM Blind XSS Version 2

> Attackers can achieve full account takeover and privilege escalation via stored DOM XSS in the backup module filename field of CI4MS.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-qxpq-82f3-xj47

## What is CVE-2026-41201?

CVE-2026-41201 is a critical cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. In version 0.31.4.0, an attacker can achieve Full Account Takeover & Privilege Escalation via Stored DOM XSS in backup module filename field manipulated via a sql file that tampers with the file name field to contain hidden XSS payload. This issue has been patched in version 0.31.5.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41201?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.5.0 |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.5.0 |

## How do I fix CVE-2026-41201?

Upgrade ci4-cms-erp/ci4ms to 0.31.5.0 or later.

## Is CVE-2026-41201 being exploited?

There is no known exploitation of CVE-2026-41201 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41201 and fix it if it is affected.

What it is: CVE-2026-41201 is a critical cross-site scripting vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41201 in the wild and no public exploit code.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.5.0
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41201/ (Markdown: https://insights.sbomify.com/CVE-2026-41201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41201
- OSV: https://osv.dev/vulnerability/CVE-2026-41201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41201/
Summaries are generated and may contain mistakes; the official description above is the record.
