# CVE-2026-41202: ci4ms Backup::restore is vulnerable to Zip Slip leading to RCE

> Authenticated users can achieve remote code execution by uploading a malicious ZIP archive that writes files to arbitrary locations.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-xp9f-pvvc-57p4

## What is CVE-2026-41202?

CVE-2026-41202 is a critical path traversal vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.5.0, ci4ms Backup::restore extracts user uploaded ZIP archives without validating entry names, allowing an authenticated backend user with the backup create permission to write files to arbitrary filesystem locations (Zip Slip) and achieve remote code execution by dropping a PHP file under the public web root. This issue has been patched in version 0.31.5.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41202?

2 open source packages ship an affected version, including ci4-cms-erp/ci4ms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.5.0 |
| `ci4-cms-erp/ci4ms` | Packagist | All versions | 0.31.5.0 |

## How do I fix CVE-2026-41202?

Upgrade ci4-cms-erp/ci4ms to 0.31.5.0 or later.

## Is CVE-2026-41202 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41202 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41202 and fix it if it is affected.

What it is: CVE-2026-41202 is a critical path traversal vulnerability in ci4-cms-erp ci4ms, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41202 exists.

Affected packages and fixed versions:
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.5.0
- ci4-cms-erp/ci4ms (Packagist): affected all versions; fixed in 0.31.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41202/ (Markdown: https://insights.sbomify.com/CVE-2026-41202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41202
- OSV: https://osv.dev/vulnerability/CVE-2026-41202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41202/
Summaries are generated and may contain mistakes; the official description above is the record.
