{"answers":{"affected":"2 open source packages ship an affected version, including @paperclipai/server. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41208 exists.","fix":"Upgrade @paperclipai/server to 2026.416.0 or later.","what":"CVE-2026-41208 is a high-severity command injection vulnerability in @paperclipai/server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41208 and fix it if it is affected.\n\nWhat it is: CVE-2026-41208 is a high-severity command injection vulnerability in @paperclipai/server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41208 exists.\n\nAffected packages and fixed versions:\n- @paperclipai/server (npm): affected all versions; fixed in 2026.416.0\n- @paperclipai/server (npm): affected all versions; fixed in 2026.416.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41208/ (Markdown: https://insights.sbomify.com/CVE-2026-41208/index.md)","id":"CVE-2026-41208","markdown":"https://insights.sbomify.com/CVE-2026-41208/index.md","name":"CVE-2026-41208","record":{"aliases":["GHSA-265w-rf2w-cjh4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"AI agent orchestration server","requires_auth":"low_privilege","summary":"An attacker with an agent API key can inject shell commands into server configuration, leading to arbitrary code execution and privilege escalation on the host.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"paperclipai","vendor":"paperclip"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Paperclip is a Node.js server and React UI that orchestrates a team of AI agents to run a business. Versions of @paperclipai/server prior to 2026.416.0 contain a privilege escalation vulnerability that allows an attacker with an Agent API key to execute arbitrary OS commands on the Paperclip server host. An attacker with an agent credential can escalate privileges from the agent runtime to the Paperclip server host. The vulnerability occurs because agents are allowed to update their own adapterConfig via the /agents/:id API endpoint. The configuration field adapterConfig.workspaceStrategy.provisionCommand is later executed by the server runtime. As a result, an attacker controlling an agent credential can inject arbitrary shell commands which are executed by the Paperclip server during workspace provisioning. This breaks the intended trust boundary between agent runtime configuration and server host execution, allowing a compromised or malicious agent to escalate privileges and run commands on the host system. This vulnerability allows remote code execution on the server host. @paperclipai/server version 2026.416.0 fixes the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution","id":"CVE-2026-41208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Moonlight Qt: Remote heap buffer overflow in Moonlight Qt H.264 SPS fixup path via crafted seq_parameter_set_id","id":"CVE-2026-41210"},"packages":[{"ecosystem":"npm","fixed":["2026.416.0"],"introduced":["0"],"last_affected":[],"package":"@paperclipai/server","purl":null,"source":"GHSA-265w-rf2w-cjh4"},{"ecosystem":"npm","fixed":["2026.416.0"],"introduced":["0"],"last_affected":[],"package":"@paperclipai/server","purl":"pkg:npm/%40paperclipai/server","source":"GHSA-265w-rf2w-cjh4"}],"prev":{"headline":"netty-incubator-codec-ohttp's HPKEContext operations may produce empty byte[] on failures","id":"CVE-2026-41207"},"products":["@paperclipai/server"],"published":"2026-04-23","related":[{"cvss_score":10,"headline":"Paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass","id":"CVE-2026-41679","kev_date_added":null,"published":"2026-04-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["paperclipai"]},"summary":"An attacker with an agent API key can inject shell commands into server configuration, leading to arbitrary code execution and privilege escalation on the host.","url":"https://insights.sbomify.com/CVE-2026-41208/"}