# CVE-2026-41208: Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution

> An attacker with an agent API key can inject shell commands into server configuration, leading to arbitrary code execution and privilege escalation on the host.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-265w-rf2w-cjh4

## What is CVE-2026-41208?

CVE-2026-41208 is a high-severity command injection vulnerability in @paperclipai/server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Paperclip is a Node.js server and React UI that orchestrates a team of AI agents to run a business. Versions of @paperclipai/server prior to 2026.416.0 contain a privilege escalation vulnerability that allows an attacker with an Agent API key to execute arbitrary OS commands on the Paperclip server host. An attacker with an agent credential can escalate privileges from the agent runtime to the Paperclip server host. The vulnerability occurs because agents are allowed to update their own adapterConfig via the /agents/:id API endpoint. The configuration field adapterConfig.workspaceStrategy.provisionCommand is later executed by the server runtime. As a result, an attacker controlling an agent credential can inject arbitrary shell commands which are executed by the Paperclip server during workspace provisioning. This breaks the intended trust boundary between agent runtime configuration and server host execution, allowing a compromised or malicious agent to escalate privileges and run commands on the host system. This vulnerability allows remote code execution on the server host. @paperclipai/server version 2026.416.0 fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-41208?

2 open source packages ship an affected version, including @paperclipai/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@paperclipai/server` | npm | All versions | 2026.416.0 |
| `@paperclipai/server` | npm | All versions | 2026.416.0 |

Products: Paperclip Paperclipai.

## How do I fix CVE-2026-41208?

Upgrade @paperclipai/server to 2026.416.0 or later.

## Is CVE-2026-41208 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41208 exists.

## Other vulnerabilities in @paperclipai/server

- [CVE-2026-41679](https://insights.sbomify.com/CVE-2026-41679/): Paperclip Vulnerable to Unauthenticated Remote Code Execution via Import Authorization Bypass (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41208 and fix it if it is affected.

What it is: CVE-2026-41208 is a high-severity command injection vulnerability in @paperclipai/server, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41208 exists.

Affected packages and fixed versions:
- @paperclipai/server (npm): affected all versions; fixed in 2026.416.0
- @paperclipai/server (npm): affected all versions; fixed in 2026.416.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41208/ (Markdown: https://insights.sbomify.com/CVE-2026-41208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41208
- OSV: https://osv.dev/vulnerability/CVE-2026-41208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41208/
Summaries are generated and may contain mistakes; the official description above is the record.
