# CVE-2026-41211: `vite-plus/binding` has path traversal `downloadPackageManager()` that leads to writes outside of `VP_HOME`

> Attackers can exploit path traversal in downloadPackageManager to write files outside the cache directory, potentially leading to code execution.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-33r3-4whc-44c2

## What is CVE-2026-41211?

CVE-2026-41211 is a high-severity path traversal vulnerability in voidzero-dev vite-plus, published on 23 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Vite+ is a unified toolchain and entry point for web development. Prior to version 0.1.17, `downloadPackageManager()` accepts an untrusted `version` string and uses it directly in filesystem paths. A caller can supply `../` segments or an absolute path to escape the `VP_HOME/package_manager/<pm>/` cache root and make Vite+ delete, replace, and populate directories outside the intended cache location. Version 0.1.17 contains a patch.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-41211?

2 open source packages ship an affected version, including vite-plus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite-plus` | npm | All versions | 0.1.17 |
| `vite-plus` | npm | All versions | 0.1.17 |

Products: Voidzero Vite\+.

## How do I fix CVE-2026-41211?

Upgrade vite-plus to 0.1.17 or later.

## Is CVE-2026-41211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41211 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41211 and fix it if it is affected.

What it is: CVE-2026-41211 is a high-severity path traversal vulnerability in voidzero-dev vite-plus, published on 23 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41211 exists.

Affected packages and fixed versions:
- vite-plus (npm): affected all versions; fixed in 0.1.17
- vite-plus (npm): affected all versions; fixed in 0.1.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41211/ (Markdown: https://insights.sbomify.com/CVE-2026-41211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41211
- OSV: https://osv.dev/vulnerability/CVE-2026-41211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41211/
Summaries are generated and may contain mistakes; the official description above is the record.
