{"answers":{"affected":"2 open source packages ship an affected version, including @node-oauth/oauth2-server. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41213 exists.","fix":"Upgrade @node-oauth/oauth2-server to 5.3.0 or later.","what":"CVE-2026-41213 is a medium-severity vulnerability in node-oauth2-server, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41213 and fix it if it is affected.\n\nWhat it is: CVE-2026-41213 is a medium-severity vulnerability in node-oauth2-server, published on 23 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41213 exists.\n\nAffected packages and fixed versions:\n- @node-oauth/oauth2-server (npm): affected all versions; fixed in 5.3.0\n- @node-oauth/oauth2-server (npm): affected all versions; fixed in 5.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41213/ (Markdown: https://insights.sbomify.com/CVE-2026-41213/index.md)","id":"CVE-2026-41213","markdown":"https://insights.sbomify.com/CVE-2026-41213/index.md","name":"CVE-2026-41213","record":{"aliases":["GHSA-jhm7-29pj-4xvf"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js OAuth2 library","requires_auth":"none","summary":"Attackers can brute-force PKCE code_verifiers to redeem intercepted authorization codes and gain unauthorized access.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"node-oauth\\/oauth2-server","vendor":"node-oauth"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-307","name":"Improper Restriction of Excessive Authentication Attempts"},{"id":"CWE-1289","name":"Improper Validation of Unsafe Equivalence in Input"}],"description":"@node-oauth/oauth2-server is a module for implementing an OAuth2 server in Node.js. The token exchange path accepts RFC7636-invalid code_verifier values (including one-character strings) for S256 PKCE flows. Because short/weak verifiers are accepted and failed verifier attempts do not consume the authorization code, an attacker who intercepts an authorization code can brute-force code_verifier guesses online until token issuance succeeds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"@node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes","id":"CVE-2026-41213","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"An invalid pointer dereference vulnerability exists in the vtkPNGReader::ExecuteInformation functionality of vtk 9.6.","id":"CVE-2026-41216"},"packages":[{"ecosystem":"npm","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"@node-oauth/oauth2-server","purl":null,"source":"GHSA-jhm7-29pj-4xvf"},{"ecosystem":"npm","fixed":["5.3.0"],"introduced":["0"],"last_affected":[],"package":"@node-oauth/oauth2-server","purl":"pkg:npm/%40node-oauth/oauth2-server","source":"GHSA-jhm7-29pj-4xvf"}],"prev":{"headline":"`vite-plus/binding` has path traversal `downloadPackageManager()` that leads to writes outside of `VP_HOME`","id":"CVE-2026-41211"},"products":["node-oauth2-server"],"published":"2026-04-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-25","vendors":["node-oauth"]},"summary":"Attackers can brute-force PKCE code_verifiers to redeem intercepted authorization codes and gain unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-41213/"}