{"answers":{"affected":"2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41228 exists.","fix":"Upgrade froxlor/froxlor to 2.3.6 or later.","what":"CVE-2026-41228 is a critical path traversal vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-41228 and fix it if it is affected.\n\nWhat it is: CVE-2026-41228 is a critical path traversal vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41228 exists.\n\nAffected packages and fixed versions:\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6\n- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41228/ (Markdown: https://insights.sbomify.com/CVE-2026-41228/index.md)","id":"CVE-2026-41228","markdown":"https://insights.sbomify.com/CVE-2026-41228/index.md","name":"CVE-2026-41228","record":{"aliases":["GHSA-w59f-67xm-rxx7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Server administration software","requires_auth":"low_privilege","summary":"Authenticated users can exploit path traversal in the language parameter to achieve remote code execution on the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"froxlor","vendor":"froxlor"}],"cvss":{"score":10,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"}],"description":"Froxlor is open source server administration software. Prior to version 2.3.6, the Froxlor API endpoint `Customers.update` (and `Admins.update`) does not validate the `def_language` parameter against the list of available language files. An authenticated customer can set `def_language` to a path traversal payload (e.g., `../../../../../var/customers/webs/customer1/evil`), which is stored in the database. On subsequent requests, `Language::loadLanguage()` constructs a file path using this value and executes it via `require`, achieving arbitrary PHP code execution as the web server user. Version 2.3.6 fixes the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution","id":"CVE-2026-41228","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API)","id":"CVE-2026-41229"},"packages":[{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":null,"source":"GHSA-w59f-67xm-rxx7"},{"ecosystem":"Packagist","fixed":["2.3.6"],"introduced":["0"],"last_affected":[],"package":"froxlor/froxlor","purl":"pkg:composer/froxlor/froxlor","source":"GHSA-w59f-67xm-rxx7"}],"prev":{"headline":"BIG-IP HTTP/2 Layer 7 Dos Protection vulnerability","id":"CVE-2026-41227"},"products":["froxlor"],"published":"2026-04-23","related":[{"cvss_score":9.9,"headline":"Improper Link Resolution Before File Access in froxlor/froxlor","id":"CVE-2023-6069","kev_date_added":null,"published":"2023-11-10"},{"cvss_score":9.9,"headline":"Code Injection in froxlor/froxlor","id":"CVE-2023-0671","kev_date_added":null,"published":"2023-02-04"},{"cvss_score":9.8,"headline":"Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor","id":"CVE-2023-3173","kev_date_added":null,"published":"2023-06-09"},{"cvss_score":9.8,"headline":"Authentication Bypass by Primary Weakness in froxlor/froxlor","id":"CVE-2023-1307","kev_date_added":null,"published":"2023-03-10"},{"cvss_score":9.8,"headline":"Froxlor SQL injection vulnerability","id":"CVE-2021-42325","kev_date_added":null,"published":"2021-10-12"},{"cvss_score":9.8,"headline":"Information disclosure in n/a","id":"CVE-2015-5959","kev_date_added":null,"published":"2017-09-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["froxlor"]},"summary":"Authenticated users can exploit path traversal in the language parameter to achieve remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2026-41228/"}