# CVE-2026-41228: Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution

> Authenticated users can exploit path traversal in the language parameter to achieve remote code execution on the server.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-w59f-67xm-rxx7

## What is CVE-2026-41228?

CVE-2026-41228 is a critical path traversal vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to version 2.3.6, the Froxlor API endpoint `Customers.update` (and `Admins.update`) does not validate the `def_language` parameter against the list of available language files. An authenticated customer can set `def_language` to a path traversal payload (e.g., `../../../../../var/customers/webs/customer1/evil`), which is stored in the database. On subsequent requests, `Language::loadLanguage()` constructs a file path using this value and executes it via `require`, achieving arbitrary PHP code execution as the web server user. Version 2.3.6 fixes the issue.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2026-41228?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |

Products: Froxlor Froxlor.

## How do I fix CVE-2026-41228?

Upgrade froxlor/froxlor to 2.3.6 or later.

## Is CVE-2026-41228 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41228 exists.

## Other vulnerabilities in froxlor

- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)
- [CVE-2021-42325](https://insights.sbomify.com/CVE-2021-42325/): Froxlor SQL injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41228 and fix it if it is affected.

What it is: CVE-2026-41228 is a critical path traversal vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41228 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41228/ (Markdown: https://insights.sbomify.com/CVE-2026-41228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41228
- OSV: https://osv.dev/vulnerability/CVE-2026-41228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41228/
Summaries are generated and may contain mistakes; the official description above is the record.
