# CVE-2026-41229: Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API)

> An admin can inject arbitrary PHP code via the MySQL server API, leading to remote code execution on the web server.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-gc9w-cc93-rjv8

## What is CVE-2026-41229?

CVE-2026-41229 is a critical code injection vulnerability in froxlor, published on 23 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to version 2.3.6, `PhpHelper::parseArrayToString()` writes string values into single-quoted PHP string literals without escaping single quotes. When an admin with `change_serversettings` permission adds or updates a MySQL server via the API, the `privileged_user` parameter (which has no input validation) is written unescaped into `lib/userdata.inc.php`. Since this file is `require`d on every request via `Database::getDB()`, an attacker can inject arbitrary PHP code that executes as the web server user on every subsequent page load. Version 2.3.6 contains a patch.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-41229?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |

Products: Froxlor Froxlor.

## How do I fix CVE-2026-41229?

Upgrade froxlor/froxlor to 2.3.6 or later.

## Is CVE-2026-41229 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41229 exists.

## Other vulnerabilities in froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41229 and fix it if it is affected.

What it is: CVE-2026-41229 is a critical code injection vulnerability in froxlor, published on 23 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41229 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41229/ (Markdown: https://insights.sbomify.com/CVE-2026-41229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41229
- OSV: https://osv.dev/vulnerability/CVE-2026-41229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41229/
Summaries are generated and may contain mistakes; the official description above is the record.
