# CVE-2026-41230: Froxlor has a BIND Zone File Injection via Unsanitized DNS Record Content in DomainZones::add()

> Authenticated users can inject arbitrary DNS records and BIND directives into zone files due to unsanitized input, potentially leading to code execution or data modification.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-47hf-23pw-3m8c

## What is CVE-2026-41230?

CVE-2026-41230 is a high-severity code injection vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to version 2.3.6, `DomainZones::add()` accepts arbitrary DNS record types without a whitelist and does not sanitize newline characters in the `content` field. When a DNS type not covered by the if/elseif validation chain is submitted (e.g., `NAPTR`, `PTR`, `HINFO`), content validation is entirely bypassed. Embedded newline characters in the content survive `trim()` processing, are stored in the database, and are written directly into BIND zone files via `DnsEntry::__toString()`. An authenticated customer can inject arbitrary DNS records and BIND directives (`$INCLUDE`, `$ORIGIN`, `$GENERATE`) into their domain's zone file. Version 2.3.6 fixes the issue.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-41230?

2 open source packages ship an affected version, including froxlor/froxlor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.6 |

Products: Froxlor Froxlor.

## How do I fix CVE-2026-41230?

Upgrade froxlor/froxlor to 2.3.6 or later.

## Is CVE-2026-41230 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41230 exists.

## Other vulnerabilities in froxlor

- [CVE-2026-41228](https://insights.sbomify.com/CVE-2026-41228/): Froxlor has Local File Inclusion via path traversal in API `def_language` parameter that leads to Remote Code Execution (critical 10.0)
- [CVE-2023-6069](https://insights.sbomify.com/CVE-2023-6069/): Improper Link Resolution Before File Access in froxlor/froxlor (critical 9.9)
- [CVE-2023-0671](https://insights.sbomify.com/CVE-2023-0671/): Code Injection in froxlor/froxlor (critical 9.9)
- [CVE-2023-3173](https://insights.sbomify.com/CVE-2023-3173/): Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor (critical 9.8)
- [CVE-2023-1307](https://insights.sbomify.com/CVE-2023-1307/): Authentication Bypass by Primary Weakness in froxlor/froxlor (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41230 and fix it if it is affected.

What it is: CVE-2026-41230 is a high-severity code injection vulnerability in froxlor, published on 23 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41230 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41230/ (Markdown: https://insights.sbomify.com/CVE-2026-41230/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41230
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41230
- OSV: https://osv.dev/vulnerability/CVE-2026-41230

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41230/
Summaries are generated and may contain mistakes; the official description above is the record.
