# CVE-2026-41234: Froxlor: BIND Zone File Injection via TXT Record Content

> Authenticated users can inject BIND directives into zone files via unsanitized TXT records, potentially leading to code execution or data modification.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 4 Jun 2026
- **Also known as:** GHSA-37m5-m4q3-fc6x

## What is CVE-2026-41234?

CVE-2026-41234 is a high-severity code injection vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Prior to version 2.3.7, the `DomainZones.add` API endpoint does not sanitize newline characters in TXT record content. An authenticated customer with DNS editing enabled can inject newlines into TXT record values, which break out of the record line in the generated BIND zone file. This enables injection of arbitrary BIND directives (`$INCLUDE`, `$GENERATE`) and arbitrary DNS records (A, MX, CNAME) into the zone file written to disk by the DNS rebuild cron. This is an incomplete fix for CVE-2026-30932 (GHSA-x6w6-2xwp-3jh6), which patched the same newline injection for LOC, RP, SSHFP, and TLSA record types but did not patch TXT records. Version 2.3.7 contains an updated patch.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-41234?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |

## How do I fix CVE-2026-41234?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-41234 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41234 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41234 and fix it if it is affected.

What it is: CVE-2026-41234 is a high-severity code injection vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41234 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41234/ (Markdown: https://insights.sbomify.com/CVE-2026-41234/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41234
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41234
- OSV: https://osv.dev/vulnerability/CVE-2026-41234

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41234/
Summaries are generated and may contain mistakes; the official description above is the record.
