# CVE-2026-41235: Froxlor has an authorization bypass in FTP shell assignment via missing server-side `available_shells` enforcement

> Authenticated customers can bypass shell restrictions to gain host shell access if shell delegation is enabled and nssextrausers is used.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-gcv3-5v9q-fmhh

## What is CVE-2026-41235?

CVE-2026-41235 is a high-severity missing authorization vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Version 2.3.6 lets administrators configure `system.available_shells` as the approved shell list that customers may assign to FTP users. However, the server-side FTP account handlers do not enforce that whitelist when processing add or edit requests. As a result, an authenticated customer with shell delegation enabled can submit an arbitrary shell such as `/bin/bash` even when the panel UI only offers more restricted choices. In deployments that use the default `nssextrausers` integration, the attacker-controlled shell is then propagated into the system account database, leading to real host shell access. Version 2.3.7 fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-41235?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | From 2.3.6 | 2.3.7 |
| `froxlor/froxlor` | Packagist | From 2.3.6 | 2.3.7 |

## How do I fix CVE-2026-41235?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-41235 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41235 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41235 and fix it if it is affected.

What it is: CVE-2026-41235 is a high-severity missing authorization vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41235 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected from 2.3.6; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected from 2.3.6; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41235/ (Markdown: https://insights.sbomify.com/CVE-2026-41235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41235
- OSV: https://osv.dev/vulnerability/CVE-2026-41235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41235/
Summaries are generated and may contain mistakes; the official description above is the record.
