# CVE-2026-41236: Froxlor has privilege escalation in SSH key synchronization via symlinked `authorized_keys` path

> An attacker with a shell-enabled customer account can symlink authorized_keys to root's file, gaining root SSH access via Froxlor's key synchronization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-mq5v-pxpm-8jw2

## What is CVE-2026-41236?

CVE-2026-41236 is a high-severity path traversal vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. Version 2.3.6 contains a symlink-following flaw in the root-owned SSH key synchronization path used for customer FTP users. The provisioning code appends public keys to `~/.ssh/authorized_keys` under a customer-controlled home directory without verifying that the target path is not a symbolic link. If an attacker controls a shell-enabled customer account and can modify files inside the assigned home directory, the attacker can replace `~/.ssh/authorized_keys` with a symlink to `/root/.ssh/authorized_keys`. When Froxlor's privileged cron task later synchronizes SSH keys, it appends the attacker-supplied key into root's authorized key file, resulting in root SSH access. Version 2.3.7 contains a patch.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-41236?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | From 2.3.6 | 2.3.7 |
| `froxlor/froxlor` | Packagist | From 2.3.6 | 2.3.7 |

## How do I fix CVE-2026-41236?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-41236 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41236 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41236 and fix it if it is affected.

What it is: CVE-2026-41236 is a high-severity path traversal vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41236 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected from 2.3.6; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected from 2.3.6; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41236/ (Markdown: https://insights.sbomify.com/CVE-2026-41236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41236
- OSV: https://osv.dev/vulnerability/CVE-2026-41236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41236/
Summaries are generated and may contain mistakes; the official description above is the record.
