# CVE-2026-41237: Froxlor has an incomplete fix for CVE-2026-30932

> Attackers can inject malformed DNS records due to incomplete input validation in Froxlor, potentially bypassing security checks or corrupting data.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 5 Jun 2026
- **Also known as:** GHSA-j6fm-9rfm-j5hx

## What is CVE-2026-41237?

CVE-2026-41237 is a high-severity vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor is open source server administration software. In version 2.3.6 and earlier, the LOC record regex uses `\s+` which matches newlines (allowing embedded newlines to pass), TLSA `matchingType=0` has no upper bound on hex data length, and all validators return raw input without zone-file escaping. Version 2.3.7 contains an updated patch.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2026-41237?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |
| `froxlor/froxlor` | Packagist | All versions | 2.3.7 |

## How do I fix CVE-2026-41237?

Upgrade froxlor/froxlor to 2.3.7 or later.

## Is CVE-2026-41237 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41237 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41237 and fix it if it is affected.

What it is: CVE-2026-41237 is a high-severity vulnerability in froxlor, published on 4 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41237 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41237/ (Markdown: https://insights.sbomify.com/CVE-2026-41237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41237
- OSV: https://osv.dev/vulnerability/CVE-2026-41237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41237/
Summaries are generated and may contain mistakes; the official description above is the record.
