{"answers":{"affected":"3 open source packages ship an affected version, including pretalx. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-41241 in the wild and no public exploit code.","fix":"Upgrade pretalx to 2026.1.0 or later.","what":"CVE-2026-41241 is a high-severity cross-site scripting vulnerability in pretalx, published on 23 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-41241 and fix it if it is affected.\n\nWhat it is: CVE-2026-41241 is a high-severity cross-site scripting vulnerability in pretalx, published on 23 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-41241 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pretalx (PyPI): affected all versions; fixed in 2026.1.0\n- pretalx (PyPI): affected all versions; fixed in 2026.1.0\n- pretalx (PyPI): affected all versions; fixed in 2026.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-41241/ (Markdown: https://insights.sbomify.com/CVE-2026-41241/index.md)","id":"CVE-2026-41241","markdown":"https://insights.sbomify.com/CVE-2026-41241/index.md","name":"CVE-2026-41241","record":{"aliases":["GHSA-cjcx-jfp2-f7m2","PYSEC-2026-108"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Conference planning tool","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via user-controlled fields that execute in administrators' browsers during search operations.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pretalx","vendor":"pretalx"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"pretalx is a conference planning tool. Prior to 2026.1.0, The organiser search in the pretalx backend rendered submission titles, speaker display names, and user names/emails into the result dropdown using innerHTML string interpolation. Any user who controls one of those fields (which includes any registered user whose display name is looked up by an administrator) could include HTML or JavaScript that would execute in an organiser's browser when the organiser's search query matched the malicious record. This vulnerability is fixed in 2026.1.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pretalx: Stored cross-site scripting in organiser search typeahead","id":"CVE-2026-41241","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"protobufjs has an arbitrary code execution issue","id":"CVE-2026-41242"},"packages":[{"ecosystem":"PyPI","fixed":["2026.1.0"],"introduced":["0"],"last_affected":[],"package":"pretalx","purl":null,"source":"GHSA-cjcx-jfp2-f7m2"},{"ecosystem":"PyPI","fixed":["2026.1.0"],"introduced":["0"],"last_affected":[],"package":"pretalx","purl":"pkg:pypi/pretalx","source":"GHSA-cjcx-jfp2-f7m2"},{"ecosystem":"PyPI","fixed":["2026.1.0"],"introduced":["0"],"last_affected":[],"package":"pretalx","purl":"pkg:pypi/pretalx","source":"PYSEC-2026-108"}],"prev":{"headline":"DOMPurify: FORBID_TAGS bypassed by function-based ADD_TAGS predicate (asymmetry with FORBID_ATTR fix)","id":"CVE-2026-41240"},"products":["pretalx"],"published":"2026-04-23","related":[{"cvss_score":6.5,"headline":"pretalx vulnerable to path traversal in HTML export","id":"CVE-2023-28459","kev_date_added":null,"published":"2023-04-20"},{"cvss_score":6.1,"headline":"pretalx: Email injection via unescaped user-controlled placeholders in pretalx mail templates","id":"CVE-2026-41426","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":4.3,"headline":"pretalx allows path traversal in HTML export","id":"CVE-2023-28458","kev_date_added":null,"published":"2023-04-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-23","vendors":["pretalx"]},"summary":"Attackers can inject malicious scripts via user-controlled fields that execute in administrators' browsers during search operations.","url":"https://insights.sbomify.com/CVE-2026-41241/"}