# CVE-2026-41241: pretalx: Stored cross-site scripting in organiser search typeahead

> Attackers can inject malicious scripts via user-controlled fields that execute in administrators' browsers during search operations.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Apr 2026
- **Updated:** 23 Apr 2026
- **Also known as:** GHSA-cjcx-jfp2-f7m2, PYSEC-2026-108

## What is CVE-2026-41241?

CVE-2026-41241 is a high-severity cross-site scripting vulnerability in pretalx, published on 23 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

pretalx is a conference planning tool. Prior to 2026.1.0, The organiser search in the pretalx backend rendered submission titles, speaker display names, and user names/emails into the result dropdown using innerHTML string interpolation. Any user who controls one of those fields (which includes any registered user whose display name is looked up by an administrator) could include HTML or JavaScript that would execute in an organiser's browser when the organiser's search query matched the malicious record. This vulnerability is fixed in 2026.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-41241?

3 open source packages ship an affected version, including pretalx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pretalx` | PyPI | All versions | 2026.1.0 |
| `pretalx` | PyPI | All versions | 2026.1.0 |
| `pretalx` | PyPI | All versions | 2026.1.0 |

Products: Pretalx Pretalx.

## How do I fix CVE-2026-41241?

Upgrade pretalx to 2026.1.0 or later.

## Is CVE-2026-41241 being exploited?

There is no known exploitation of CVE-2026-41241 in the wild and no public exploit code.

## Other vulnerabilities in pretalx

- [CVE-2023-28459](https://insights.sbomify.com/CVE-2023-28459/): pretalx vulnerable to path traversal in HTML export (medium 6.5)
- [CVE-2026-41426](https://insights.sbomify.com/CVE-2026-41426/): pretalx: Email injection via unescaped user-controlled placeholders in pretalx mail templates (medium 6.1)
- [CVE-2023-28458](https://insights.sbomify.com/CVE-2023-28458/): pretalx allows path traversal in HTML export (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41241 and fix it if it is affected.

What it is: CVE-2026-41241 is a high-severity cross-site scripting vulnerability in pretalx, published on 23 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-41241 in the wild and no public exploit code.

Affected packages and fixed versions:
- pretalx (PyPI): affected all versions; fixed in 2026.1.0
- pretalx (PyPI): affected all versions; fixed in 2026.1.0
- pretalx (PyPI): affected all versions; fixed in 2026.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41241/ (Markdown: https://insights.sbomify.com/CVE-2026-41241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41241
- OSV: https://osv.dev/vulnerability/CVE-2026-41241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41241/
Summaries are generated and may contain mistakes; the official description above is the record.
