# CVE-2026-41244: Mojic: Observable Timing Discrepancy in HMAC Verification

> An attacker can bypass file integrity checks in Mojic by exploiting timing discrepancies in HMAC verification, potentially allowing tampered code execution.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-wqq3-wfmp-v85g

## What is CVE-2026-41244?

CVE-2026-41244 is a medium-severity vulnerability in notamitgamer mojic, published on 24 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Mojic is a CLI tool to transform readable C code into an unrecognizable chaotic stream of emojis. Prior to 2.1.4, the CipherEngine uses a standard equality operator (!==) to verify the HMAC-SHA256 integrity seal during the decryption phase. This creates an Observable Timing Discrepancy (CWE-208), allowing a potential attacker to bypass the file integrity check via a timing attack. This vulnerability is fixed in 2.1.4.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-41244?

2 open source packages ship an affected version, including mojic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mojic` | npm | All versions | 2.1.4 |
| `mojic` | npm | All versions | 2.1.4 |

## How do I fix CVE-2026-41244?

Upgrade mojic to 2.1.4 or later.

## Is CVE-2026-41244 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41244 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41244 and fix it if it is affected.

What it is: CVE-2026-41244 is a medium-severity vulnerability in notamitgamer mojic, published on 24 Apr 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41244 exists.

Affected packages and fixed versions:
- mojic (npm): affected all versions; fixed in 2.1.4
- mojic (npm): affected all versions; fixed in 2.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41244/ (Markdown: https://insights.sbomify.com/CVE-2026-41244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41244
- OSV: https://osv.dev/vulnerability/CVE-2026-41244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41244/
Summaries are generated and may contain mistakes; the official description above is the record.
