# CVE-2026-41254: Integer overflow in little cms color engine

> An integer overflow in Little CMS allows attackers to cause denial of service or potentially execute code via crafted color profiles.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2026
- **Updated:** 7 May 2026
- **Also known as:** ALPINE-CVE-2026-41254, AZL-83075, AZL-83081, BELL-CVE-2026-41254, BIT-java-2026-41254, BIT-java-min-2026-41254, BIT-jre-2026-41254, DEBIAN-CVE-2026-41254, ECHO-9584-7cf3-54ec, GHSA-4xp6-rcgg-m9qq, GHSA-hc77-37fq-x324, JLSEC-2026-491, MGASA-2026-0214, MINI-2p69-cp3j-jx89, MINI-372v-69vr-vmx8, MINI-373r-5w73-h8cv, MINI-4wpf-v3m7-97h9, MINI-5h7p-g888-r62w, MINI-5mx5-wvc3-vhxx, MINI-5v6r-vx65-wg2q, MINI-62rw-gwg3-rh5c, MINI-63q3-cm3f-pqgp, MINI-6c86-4hmf-xq53, MINI-768p-rc95-4326, MINI-7874-7r7c-wwf4, MINI-82q4-4f46-cvv7, MINI-89fm-9gxw-cc45, MINI-96g5-367x-6h7w, MINI-97r9-q8g9-v7jm, MINI-cmpp-37m7-78rq, MINI-gv64-ph67-v427, MINI-h548-56fp-3phc, MINI-hr3v-6675-qj2x, MINI-j36g-rqqm-wx8r, MINI-jh4w-385j-95rf, MINI-m24h-g7xh-qq52, MINI-p3gr-78w2-x2cm, MINI-p5gm-qr2c-vg7m, MINI-q4gf-p9rj-hcmf, MINI-vfxx-mg2v-jwrj, MINI-vj68-p9rp-m2pf, OESA-2026-2128, SUSE-SU-2026:3964-1, SUSE-SU-2026:4056-1, SUSE-SU-2026:4205-1, UBUNTU-CVE-2026-41254, USN-8209-2

## What is CVE-2026-41254?

CVE-2026-41254 is a medium-severity vulnerability in littlecms little cms color engine, published on 18 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Little CMS (lcms2) through 2.18 has an integer overflow in CubeSize in cmslut.c because the overflow check is performed after the multiplication.

Weakness: CWE-190 (Integer Overflow or Wraparound), CWE-696 (Incorrect Behavior Order)

## Which versions are affected by CVE-2026-41254?

3 open source packages ship an affected version, including java, java-min and jre. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2 |
| `lcms2` | SUSE:Linux Enterprise Micro 5.3 | All versions | 2.12-150400.3.3.1 |
| `lcms2` | SUSE:Linux Enterprise Micro 5.4 | All versions | 2.12-150400.3.3.1 |
| `lcms2` | SUSE:Linux Enterprise Micro 5.5 | All versions | 2.12-150400.3.3.1 |
| `lcms2` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 2.15-150600.3.6.1 |
| `lcms2` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 2.15-150600.3.6.1 |
| `lcms2` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 2.7-9.13.1 |

Products: Littlecms Little Cms.

## How do I fix CVE-2026-41254?

Upgrade java to a fixed version for your release line: 1.8.0, 8.0.501, 11.0.32 or 17.0.20.

## Is CVE-2026-41254 being exploited?

There is no known exploitation of CVE-2026-41254 in the wild and no public exploit code.

## Other vulnerabilities in littlecms little cms color engine

- [CVE-2018-11555](https://insights.sbomify.com/CVE-2018-11555/): Memory corruption in n/a (high 7.8)
- [CVE-2018-11556](https://insights.sbomify.com/CVE-2018-11556/): Memory corruption in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41254 and fix it if it is affected.

What it is: CVE-2026-41254 is a medium-severity vulnerability in littlecms little cms color engine, published on 18 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-41254 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.501, 11.0.32, 17.0.20, 21.0.12, 25.0.4, 26.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41254/ (Markdown: https://insights.sbomify.com/CVE-2026-41254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41254
- OSV: https://osv.dev/vulnerability/CVE-2026-41254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41254/
Summaries are generated and may contain mistakes; the official description above is the record.
