# CVE-2026-41255: CKAN: CSRF exemption primed by anonymous requests

> An unauthenticated request can permanently disable CSRF protection for a server worker, allowing attackers to bypass CSRF defenses in CKAN data portals.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-mcvf-jxcw-vj73, PYSEC-2026-2418

## What is CVE-2026-41255?

CVE-2026-41255 is a medium-severity vulnerability in ckan, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Prior to 2.10.10 and 2.11.5, Access to the views via tokens or unauthenticated requests marked the endpoint as not requiring CSRF protection. The marking was a member variable in flask-wtf.csrf.CSRFProtect(), which was stored as a module level variable in the flask_app middleware. This API was never intended for request level changes, it is primarily a decorator for static configuration. An unauthenticated request could hit a protected endpoint, exempting it from CSRF protection for the life of the particular server process. (e.g. one worker of uwsgi). This vulnerability is fixed in 2.10.10 and 2.11.5.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2026-41255?

5 open source packages ship an affected version, including ckan. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | From 2.10.0 | 2.10.10, 2.11.5 |
| `ckan` | PyPI | From 2.10.0 | 2.10.10 |
| `ckan` | PyPI | From 2.10.0 | 2.10.10 |
| `ckan` | PyPI | From 2.11.0 | 2.11.5 |
| `ckan` | PyPI | From 2.11.0 | 2.11.5 |

Products: Okfn Ckan.

## How do I fix CVE-2026-41255?

Upgrade ckan to a fixed version for your release line: 2.10.10 or 2.11.5.

## Is CVE-2026-41255 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41255 exists.

## Other vulnerabilities in ckan

- [CVE-2023-32321](https://insights.sbomify.com/CVE-2023-32321/): CKAN remote code execution and private information access via crafted resource ids (critical 9.8)
- [CVE-2023-32696](https://insights.sbomify.com/CVE-2023-32696/): Excessive permissions for ckan user (high 8.8)
- [CVE-2022-43685](https://insights.sbomify.com/CVE-2022-43685/): CKAN contains Improper Authentication leading to account takeover (high 8.8)
- [CVE-2023-22746](https://insights.sbomify.com/CVE-2023-22746/): CKAN is vulnerable to session secret shared across instances using Docker images (high 8.6)
- [CVE-2026-42031](https://insights.sbomify.com/CVE-2026-42031/): CKAN: Unauthenticated SQL Injection and Authorization Bypass in `datastore_search_sql` (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-41255 and fix it if it is affected.

What it is: CVE-2026-41255 is a medium-severity vulnerability in ckan, published on 13 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-41255 exists.

Affected packages and fixed versions:
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.10, 2.11.5
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.10
- ckan (PyPI): affected from 2.10.0; fixed in 2.10.10
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.5
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-41255/ (Markdown: https://insights.sbomify.com/CVE-2026-41255/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-41255
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-41255
- OSV: https://osv.dev/vulnerability/CVE-2026-41255

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-41255/
Summaries are generated and may contain mistakes; the official description above is the record.
